Check Gauges light....Battery indicator at 19.....HELP.. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Check Gauges light....Battery indicator at 19.....HELP..

Smittybilt Products at Oconee Off-Road!Alloy USA Still AvailableCurrie Currectlync Steering Upgrade Kits and Currie Anti-R

Reply
Unread 07-29-2012, 09:58 AM   #1
cgutta
Registered User
 
Join Date: Jun 2012
Location: Derry, NH
Posts: 8
Check Gauges light....Battery indicator at 19.....HELP..

I have a 2001 Jeep cherokee limited 4.0 straight 6.....It has 108,000 miles on it....I have had it for 2 months....recently the check gauges light came on and the battery indicator was pinned at 19......It was on for about 6 miles or so then went off....back to about 14 volts wich is normal, then it went back on again for a few miles....I shut the truck off clicked the key over without starting it and it read at normal voltage...started it up and for the past few days no light and it reads at normal voltage with no problems.....YET...So what I am wondering is, could it be the alternator and is the voltage regulator in the alternator or could it be the ECM, or PCM....I guess i could replace the aternator with a new one and eliminate the alternator concern...if its the ECM or PCM how pricy is that? let me know you thoughts if you have any....Thank you.

cgutta is offline   Reply With Quote
Unread 07-29-2012, 10:38 AM   #2
cbenez1
Registered User
1991 XJ Cherokee 
 
Join Date: Jun 2009
Location: Bucks County, PA
Posts: 1,611
Yes I agree.
__________________
A nation that "forgets" it's defenders, Will itself be "forgotten". Semper fi
91 XJ 4.0 5spd 5.5 on 32's, flat flares, sand camo'd. "Battle Wagon"
01 XJ 'Up Country' 3.5 on 29's former fire vehicle. Bright red. "Fire Wagon"
cbenez1 is offline   Reply With Quote
Unread 07-29-2012, 05:21 PM   #3
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 1,892
Quote:
Originally Posted by cgutta View Post
I have a 2001 Jeep cherokee limited 4.0 straight 6.....It has 108,000 miles on it....I have had it for 2 months....recently the check gauges light came on and the battery indicator was pinned at 19......It was on for about 6 miles or so then went off....back to about 14 volts wich is normal, then it went back on again for a few miles....I shut the truck off clicked the key over without starting it and it read at normal voltage...started it up and for the past few days no light and it reads at normal voltage with no problems.....YET...So what I am wondering is, could it be the alternator and is the voltage regulator in the alternator or could it be the ECM, or PCM....I guess i could replace the aternator with a new one and eliminate the alternator concern...if its the ECM or PCM how pricy is that? let me know you thoughts if you have any....Thank you.
Perhaps you should have the Alternator tested at a shop/store you can trust. But first, check the alternator bearings without removing the alternator...loosen the drive belt from the alternator pulley and turn the alternator pulley by hand and see if the bearings feel rough. Next, (detach the negative battery post connector) check the B+ cable attachment at the alternator for corrosion - remove the nut and detach the cable from the alternator and check the terminal end for corrosion. Next, remove the field control connector from the alternator and check it for corrosion. Next, make sure the battery post connections are not corroded. You may want to remove the battery and have it capacity checked at a shop/store you trust. With the battery out, inspect the battery temp sensor at the bottom of the battery tray; it has a wave washer that keeps it in contact with the bottom of the battery, which falls apart. Detach the battery temp sensor connector and check for corrosion (easy with battery removed). If everything above is okay, remove the alternator and have it tested.

The voltage regulator is in the PCM but it is doubtful that it is defective.
CCKen is offline   Reply With Quote
Unread 07-29-2012, 06:55 PM   #4
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,429
Quote:
Originally Posted by CCKen View Post
The voltage regulator is in the PCM but it is doubtful that it is defective.
True.

Perform routine maintenance of the start and charge systems. Remove, clean, and firmly reconnect all the wires and cables to the battery, starter, and alternator. Look for corroded or damaged cables or connectors and replace as needed. Do the same for the grounding wires from the starter to engine block, and from the battery and engine to the Jeep's frame/body. You must remove, scrape, and clean until shiny, the cable/wire ends, and whatever they bolt to. Jeeps do not tolerate low voltage, bad connections, or poor grounds.

As suggested, have the battery, starter, and the alternator Load Tested for proper function in a test machine that applies a simulated work load. Handheld testers are inaccurate and will often pass faulty parts.
__________________
.

According to the National Shooting Sports Foundation, AR-15 sporting rifles account for nearly 20% of all U.S. firearms sales.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problem; Government is the problem.
CJ7-Tim is offline   Reply With Quote
Unread 09-12-2012, 10:31 PM   #5
AJ1
Registered User
1998 TJ Wrangler 
 
Join Date: Aug 2012
Location: Marion, MT, Montana
Posts: 71
Did you find out what was causing this issue? Did it reoccur? I have a very similar issue with my 4.0 98 TJ. After warmed up, if I bring RPM up above 1200 for a short (15-30sec) period of time, it will peg voltmeter at 19V and Check gauges comes on. If I shut it off and restart it, it will be normal as long as RPM stays below 1200. I've even found I can shut the key off for a short enough period that I don't need the starter to restart it, flywheel still turning. I can lug it around for hours as long as I keep RPM below 1200 and voltage meter will read normal, 14V.

What I've tried so far:
First I measured voltage at the battery while recreating the problem, battery voltage read normal, 13.5-14V even when meter pegged.

Next I cleaned connections to gauge cluster and made sure they were tight when re-installed. No change.

Checked connections to PCM, all looked very good.

Then I removed and cleaned all ground and alternator connections with wire wheel on a drill. Nothing, so I also cleaned positive connections. Nothing.

Next I changed the alternator out with my stockish one, a few years ago I installed a 250A alt when I installed my winch. The stock one worked when I put it on the shelf. No change.

I also checked and the issue happens with the battery disconnected, so I don't see how it could be the battery.

I think it either has to be the PCM or Gauge Cluster. I'm leaning towards PCM because I've recently noticed the dome and floor lights seem to flicker a little after it warms up, although they do not get brighter but still kind of flicker when gauge reads 19V. They do not flicker until it has been running for 15-30sec cold.

What is the v-meter even reading? At this point I'm guessing it just reads a V or mA signal from the PCM.

Any ideas on what is causing this??
AJ1 is offline   Reply With Quote
Unread 09-13-2012, 08:37 AM   #6
GetLifted
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2010
Location: SoCal
Posts: 1,193
Its the PCM. A member over at XJsocal.com named A-Gage (Aaron) had the same problem. He bypassed the regulator in the PCM i believe and put an external one on. He says its been fine since.

You might want to contact him and ask. Good luck.

http://www.xjsocal.com/member.php?1137-A-Gage
GetLifted is offline   Reply With Quote
Unread 09-13-2012, 08:56 AM   #7
AJ1
Registered User
1998 TJ Wrangler 
 
Join Date: Aug 2012
Location: Marion, MT, Montana
Posts: 71
Thanks
AJ1 is offline   Reply With Quote
Unread 09-13-2012, 06:37 PM   #8
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,429
1) NEVER disconnect the battery when a computer controlled engine is running. You can cause a voltage spike and ruin lots of expensive electronics.

2) Test your way to the source of the problem. It ain't rocket science, alternator-wires-wire connections-battery.

PCM failure is highly unlikely and should only be considered after checking and testing all the normal, common, and obvious possibilities for the symptoms.
__________________
.

According to the National Shooting Sports Foundation, AR-15 sporting rifles account for nearly 20% of all U.S. firearms sales.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problem; Government is the problem.
CJ7-Tim is offline   Reply With Quote
Unread 09-14-2012, 07:47 PM   #9
cgutta
Registered User
 
Join Date: Jun 2012
Location: Derry, NH
Posts: 8
Problem fixed.....Brand new remanufactured aternator..(they dont make new) brand new battery...800 cca....not a problem since.
cgutta is offline   Reply With Quote
Unread 09-14-2012, 08:48 PM   #10
AJ1
Registered User
1998 TJ Wrangler 
 
Join Date: Aug 2012
Location: Marion, MT, Montana
Posts: 71
Quote:
Originally Posted by cgutta
Problem fixed.....Brand new remanufactured aternator..(they dont make new) brand new battery...800 cca....not a problem since.
Interesting... Thanks for the info. I guess I need to get a copy of the FSM, maybe it tells the normal inputs to the alternator field and v-meter. So I can see if they are correct.

I don't understand why the voltmeter reads 19v when measured voltage is 14V, maybe FSM schematics will clarify this as well.

Thanks again.
AJ1 is offline   Reply With Quote
Unread 09-14-2012, 08:49 PM   #11
AJ1
Registered User
1998 TJ Wrangler 
 
Join Date: Aug 2012
Location: Marion, MT, Montana
Posts: 71
[QUOTE="CJ7-Tim"]1) NEVER disconnect the battery when a computer controlled engine is running. You can cause a voltage spike and ruin lots of expensive electronics.


Thanks for that info, I wasn't aware of that.
AJ1 is offline   Reply With Quote
Unread 09-15-2012, 07:33 AM   #12
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,429
Quote:
Originally Posted by AJ1 View Post
....I don't understand why the voltmeter reads 19v when measured voltage is 14V.
The ECU alters the readout to the gauge to alert the driver of a problem.

With the engine running, anytime your dashboard gauge shows anything besides 12.8-14.4 volts, you have a charging system issue. It may be as simple as loose or corroded battery cables.
__________________
.

According to the National Shooting Sports Foundation, AR-15 sporting rifles account for nearly 20% of all U.S. firearms sales.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problem; Government is the problem.
CJ7-Tim is offline   Reply With Quote
Unread 09-15-2012, 07:45 AM   #13
CCKen
Web Wheeler
 
CCKen's Avatar
1999 XJ Cherokee 
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 1,892
Quote:
Originally Posted by cgutta View Post
Problem fixed.....Brand new remanufactured aternator..(they dont make new) brand new battery...800 cca....not a problem since.
Thanks for the [rare] follow-up.
CCKen is offline   Reply With Quote
Unread 09-15-2012, 04:45 PM   #14
Azzy
Web Wheeler
 
Azzy's Avatar
1996 XJ Cherokee 
 
Join Date: Sep 2010
Location: Finleyville
Posts: 3,211
They dont make new alternators? There is one in my wife's XJ.... as of about 1K miles ago.
__________________
ADW - Custom gauges, decals, and now laser engraving. Check out the gallery here.
Azzy is offline   Reply With Quote
Unread 09-29-2012, 09:44 PM   #15
AJ1
Registered User
1998 TJ Wrangler 
 
Join Date: Aug 2012
Location: Marion, MT, Montana
Posts: 71
For future reference, and if anyone cares; I took my Odyssey battery to a local dealer, they agreed that the battery was bad and gave me a new one. After installing the new battery and driving it for a couple of days the Voltage spiking to 19 volts issue has not occured again.

I should have done that first, I just didn't want to believe my almost $300 battery was bad. If I had known they would just give me a new battery I probably would have done that earlier. I didn't know/remember the battery had a 4 year free replacement warranty.
AJ1 is offline   Reply With Quote
Reply

Tags
19 volts , 9 volts , alternator , battery , check guages light
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.