Check engine light and "No Bus" on tripometer - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Check engine light and "No Bus" on tripometer

Rough Country Jeep Suspension Deals at Rockridge 4WD!Engo winches available at www.rockridge4wd.com! Free shippRoad Race Motorsports Stage 2 Power Pack

Reply
Unread 06-16-2010, 12:53 PM   #1
Mikej1224
Registered User
1999 XJ Cherokee 
 
Join Date: Oct 2008
Location: Virginia
Posts: 74
Check engine light and "No Bus" on tripometer

I had been driving for about 5 minutes yesterday, and then the check engine light came on, and on the tripometer it said "no Bus". after 10-15 seconds both the check engine light and "no Bus" message went away. i experienced no other problems with the car during or after that time. i was wondering if there is any thing i should be concerned about because of this. it is a 1999 XJ 4.0L. thank you.

Mikej1224 is offline   Reply With Quote Quick reply to this message
Unread 06-16-2010, 01:20 PM   #2
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,809
This is a common issue on 97-01 Cherokees. It is a problem with the connections at the back of the instrument cluster. There is no other problems with the Jeep. It often goes away by itself, if not you can whack the top of the dash with your hand.

Here is the real fix, remove the cluster and clean the connections. The Wrangler is similar to the Cherokee - Fix your TJ's dead gauges (write-up) - JeepForum.com
__________________
.

Between 2009 when Obama took office, and 2013, median annual household incomes have fallen by more than $2,100.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline   Reply With Quote Quick reply to this message
Unread 06-16-2010, 01:42 PM   #3
Mikej1224
Registered User
1999 XJ Cherokee 
 
Join Date: Oct 2008
Location: Virginia
Posts: 74
thanks Tim, that is most likely the issue. if it becomes a persistent problem, then i will take a look at the connections.
Mikej1224 is offline   Reply With Quote Quick reply to this message
Unread 06-16-2010, 01:54 PM   #4
franknstn_cj5
Registered User
2006 LJ Wrangler 
 
Join Date: Feb 2009
Location: Charlottesville, Virginia
Posts: 703
search search search
franknstn_cj5 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.