JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   XJ Cherokee Technical Forum (http://www.jeepforum.com/forum/f11/)
-   -   a/c stopped working after a week in Vegas (http://www.jeepforum.com/forum/f11/c-stopped-working-after-week-vegas-1407776/)

unistar 08-20-2012 04:24 PM

a/c stopped working after a week in Vegas
 
So I just moved to Las Vegas from Utah and one week into it my a/c goes out on my 2001 cherokee. It was blowing cold one day and the next it was hot. The components in the engine bay check out ok I think. The clutch on the compressor is engaging like it should. I checked some vacuum lines and they were pulling pressure. I figured it leaked the refrigerant out but the hardline going onto the firewall still gets ice cold. In the cabin everything is blowing out the right vents and all. The only problem is if I turn the knob from cold to hot it gets hot but when I turn it back to cold it stays hot. Is there a door somewhere that is stuck so it is only diverting hot air? any ideas?

unistar 08-27-2012 12:04 PM

Bump. Any ideas out there?

AZ Jeff 08-27-2012 02:02 PM

Your blend door probably is not moving. The motor for the door is on the bottom of the heater box above the trans tunnel. It is attached by three screws to the heater box. Start by taking the motor off the blend door shaft and see if it moves freely. If it does, then I suspect the axle for the blend door is broken and that means the heater box must come out to fix it.


The time now is 08:23 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.