Burnt Tranny.. - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 06-17-2013, 11:58 AM Thread Starter
XjJeff
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2009
Location: Estill,SC
Posts: 3
Burnt Tranny..

My daughter smoked the automatic trans in her 98 Cherokee. I have a auto trans from a 2000 cherokee including the TCM. Will it work in her 98 if I put the TCM in it too or will it work with the 98 TCM??????

XjJeff is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-17-2013, 01:32 PM
jeepkid03
Winning
 
jeepkid03's Avatar
2000 XJ Cherokee 
 
Join Date: Sep 2008
Location: Storrs
Posts: 6,193
The transmissions are the same, and it should work with the 1998 TCM. The harness plugs might be slightly different so you may have to splice some wires.

Just curious, what makes you think the transmission is toast? The AW4 is a pretty bullet proof transmission. I've seen them run with water in them, barely any fluid, etc. If it is a shifting issue, it could be directly related to the TPS located on the throttle body, which is much less work to replace.
jeepkid03 is offline  
post #3 of 4 Old 06-18-2013, 05:23 AM Thread Starter
XjJeff
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2009
Location: Estill,SC
Posts: 3
Well..i believe its toast due to the fact that it aas pouring fluid down the road accompanied by enough smoke to hide a semi while driving it until it came to a complete stop with the engine still revving to 3 grand. Then she asks.....daddy what happened?? It wont go any more?...17yr old girls...go figure
XjJeff is offline  
post #4 of 4 Old 06-18-2013, 08:13 AM
Paradise XJ
Registered User
1988 MJ Comanche 
 
Join Date: Jan 2007
Location: Paradise, CA
Posts: 2,424
That sounds to me more like it popped a tranny line or other major leak, lost all it's fluid, fluid landed on hot parts and created James Bond smoke screen, torque converter emptied, tranny won't go.

My 1990 XJ did this on a logging road out in the middle of nowhwere...as in 25 miles from the nearest pavement, let alone any town...same exact thing. Had to send my buddy to a parts store 40 miles away. I fixed the hose, filled it back up with tranny fluid and it's been running great ever since...that was about 6 years and 40K miles ago. Like said above the AW4 is very durable, but without any fluid, it won't go..

See if you can find where the fluid leaked out, fix that, the empty transmission will take 8-9 qts. of Dex III or >. Heck of alot cheaper and easier than a new/used tranny.

1990 XJ Laredo - White & Chrome
1988 MJ Pioneer - Metallic Green and Black
Paradise XJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome