Blend doors not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Blend doors not working

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 08-08-2012, 11:36 AM   #1
spalatucc
Registered User
1997 XJ Cherokee 
 
Join Date: Jun 2012
Location: Vienna, Virginia
Posts: 15
Blend doors not working

I just replaced my heater core, evaporator core and blower motor and before this the air would flow through all my vents fine. Now it seems the blend doors are not opening when I try to turn the air on. I made sure I reattached all the vacuum hoses in their correct positions before putting the HVAC back in as well. Any ideas why as to why it isn't working correctly now?

spalatucc is offline   Reply With Quote
Unread 08-08-2012, 04:02 PM   #2
AZ Jeff
Web Wheeler
2000 XJ Cherokee 
 
Join Date: Sep 2005
Location: San Tan Valley Arizona, AZ
Posts: 7,164
Since all the doors are vacuum operated, and you say none of them function (the are called "MODE" doors, BTW. The "BLEND" door controls air temperature), I would guess you have no vacuum going to your mode control knob. Check that first.
__________________
AZ-Jeff
1992 XJ 2" lift -- RIP
2000 XJ 3" lift -- Australian Ford Big Brakes up front, rock rails, ZJ rear discs (with WORKING parking brake), C4x4 rear bumper/tire carrier, Hella H4 headlights, IPF driving lights, OEM skid plates, OME springs/shocks, JKS LCA's, JKS Sway Bar links.
AZ Jeff is offline   Reply With Quote
Unread 08-08-2012, 06:15 PM   #3
ThaKmFb
Registered User
 
Join Date: Jul 2011
Location: Richmond, Virginia
Posts: 37
The blend door is actually cable driven. The mode doors are vacuum operated. Make sure you have a black and a gray hose goin through the firewall with the evaporator connections. The black one is the supply to the control head the gray one goes to the heater control valve. Make sure you dont have the switched. If those are o.k. check and make sure you have vacuum at the a/c control head. Then go from there.
ThaKmFb is offline   Reply With Quote
Unread 08-10-2012, 03:50 PM   #4
spalatucc
Registered User
1997 XJ Cherokee 
 
Join Date: Jun 2012
Location: Vienna, Virginia
Posts: 15
Mode door

Thanks guys for the replies. When I cycle to a different mode the doors don't open, but if I cycled all the way through and on the way back stop at the one I want it opens correctly. I made sure I plugged all the vacuum hoses up correctly (I've made the mistake of not taking pictures and documenting where things go when I rebuilt my engine). Also, I didn't even touch the one on the control knob
spalatucc is offline   Reply With Quote
Unread 08-10-2012, 05:17 PM   #5
AZ Jeff
Web Wheeler
2000 XJ Cherokee 
 
Join Date: Sep 2005
Location: San Tan Valley Arizona, AZ
Posts: 7,164
Quote:
Originally Posted by spalatucc View Post
Thanks guys for the replies. When I cycle to a different mode the doors don't open, but if I cycled all the way through and on the way back stop at the one I want it opens correctly. I made sure I plugged all the vacuum hoses up correctly (I've made the mistake of not taking pictures and documenting where things go when I rebuilt my engine). Also, I didn't even touch the one on the control knob
That sorta sounds like a control problem. Check the vacuum lines that run from the control panel to the junction block behind the glove compartment on the heater box.
__________________
AZ-Jeff
1992 XJ 2" lift -- RIP
2000 XJ 3" lift -- Australian Ford Big Brakes up front, rock rails, ZJ rear discs (with WORKING parking brake), C4x4 rear bumper/tire carrier, Hella H4 headlights, IPF driving lights, OEM skid plates, OME springs/shocks, JKS LCA's, JKS Sway Bar links.
AZ Jeff is offline   Reply With Quote
Unread 08-10-2012, 05:28 PM   #6
ThaKmFb
Registered User
 
Join Date: Jul 2011
Location: Richmond, Virginia
Posts: 37
Sounds like maybe the control head
ThaKmFb is offline   Reply With Quote
Reply

Tags
a/c , blower motor
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.