Blend doors not working - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 08-08-2012, 12:36 PM Thread Starter
spalatucc
Registered User
1997 XJ Cherokee 
 
Join Date: Jun 2012
Location: Vienna
Posts: 15
Blend doors not working

I just replaced my heater core, evaporator core and blower motor and before this the air would flow through all my vents fine. Now it seems the blend doors are not opening when I try to turn the air on. I made sure I reattached all the vacuum hoses in their correct positions before putting the HVAC back in as well. Any ideas why as to why it isn't working correctly now?

spalatucc is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-08-2012, 05:02 PM
AZ Jeff
Web Wheeler
2014 JK Wrangler 
 
Join Date: Sep 2005
Location: San Tan Valley Arizona
Posts: 7,698
Since all the doors are vacuum operated, and you say none of them function (the are called "MODE" doors, BTW. The "BLEND" door controls air temperature), I would guess you have no vacuum going to your mode control knob. Check that first.

AZ-Jeff
I don't own an XJ any longer, but I still think they are the best of all the Jeep products ever made. My XJ was my favorite vehicle in my 50+ years of driving.
So...I stick around and give advice.
AZ Jeff is offline  
post #3 of 6 Old 08-08-2012, 07:15 PM
ThaKmFb
Registered User
 
Join Date: Jul 2011
Location: Richmond
Posts: 37
The blend door is actually cable driven. The mode doors are vacuum operated. Make sure you have a black and a gray hose goin through the firewall with the evaporator connections. The black one is the supply to the control head the gray one goes to the heater control valve. Make sure you dont have the switched. If those are o.k. check and make sure you have vacuum at the a/c control head. Then go from there.
ThaKmFb is offline  
post #4 of 6 Old 08-10-2012, 04:50 PM Thread Starter
spalatucc
Registered User
1997 XJ Cherokee 
 
Join Date: Jun 2012
Location: Vienna
Posts: 15
Mode door

Thanks guys for the replies. When I cycle to a different mode the doors don't open, but if I cycled all the way through and on the way back stop at the one I want it opens correctly. I made sure I plugged all the vacuum hoses up correctly (I've made the mistake of not taking pictures and documenting where things go when I rebuilt my engine). Also, I didn't even touch the one on the control knob
spalatucc is offline  
post #5 of 6 Old 08-10-2012, 06:17 PM
AZ Jeff
Web Wheeler
2014 JK Wrangler 
 
Join Date: Sep 2005
Location: San Tan Valley Arizona
Posts: 7,698
Quote:
Originally Posted by spalatucc View Post
Thanks guys for the replies. When I cycle to a different mode the doors don't open, but if I cycled all the way through and on the way back stop at the one I want it opens correctly. I made sure I plugged all the vacuum hoses up correctly (I've made the mistake of not taking pictures and documenting where things go when I rebuilt my engine). Also, I didn't even touch the one on the control knob
That sorta sounds like a control problem. Check the vacuum lines that run from the control panel to the junction block behind the glove compartment on the heater box.

AZ-Jeff
I don't own an XJ any longer, but I still think they are the best of all the Jeep products ever made. My XJ was my favorite vehicle in my 50+ years of driving.
So...I stick around and give advice.
AZ Jeff is offline  
post #6 of 6 Old 08-10-2012, 06:28 PM
ThaKmFb
Registered User
 
Join Date: Jul 2011
Location: Richmond
Posts: 37
Sounds like maybe the control head
ThaKmFb is offline  
Reply

Tags
a/c , blower motor

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1997 xj power window/doors not working dhoge88 XJ Cherokee Technical Forum 7 03-15-2014 08:43 PM
climate control blend doors mustfade1 XJ Cherokee Technical Forum 13 10-28-2010 06:56 AM
Help with HVAC "Blend Doors" kadetklapp XJ Cherokee Technical Forum 34 11-07-2008 06:18 AM
Rear doors not working XJ Blue XJ Cherokee Technical Forum 10 12-01-2007 12:32 PM
Help! Blend doors? Willy D XJ Cherokee Technical Forum 2 03-23-2007 02:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome