Axle seal and braking pulse - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 12-02-2012, 12:29 PM Thread Starter
MrKevinRosales
Registered User
1996 XJ Cherokee 
 
Join Date: Dec 2011
Location: Willimantic
Posts: 32
Axle seal and braking pulse

The other day I changed the passenger's side wheel hub assembly on my 96 Cherokee and while I was at it I decided to do the brakes as well.
When I took it for a test drive I noticed that when coming to a stop the front right side had a sort of pulse when braking. I looked it over and everything seemed to be fine.
Today I looked at it again and I noticed that I had differential fluid coming out of the axle. I guess I must have damaged the seal when I changed the wheel hub assembly. (Even though I didn't need to, I took the whole axle shaft out that day to have a look at the axle shaft)
Could this faulty seal be the cause of the pulse I feel while braking or could it be something else?

MrKevinRosales is offline  
Reply

Tags
axle , brakes , differential fluid

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome