Any one know why my jeep wont run? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > Any one know why my jeep wont run?

*VOTE NOW Help Metalcloak Giveaway an XJ Suspension*Currie RockJock Products!!This is a shout out to all INTERNATIONAL Customers! Yes we

Reply
Unread 01-21-2011, 11:30 AM   #1
TheAlk3mist
Registered User
1995 XJ Cherokee 
 
Join Date: Jul 2010
Location: Butler PA
Posts: 26
1995 XJ Died And Wont stay Runnin

So i was driving my 1995 XJ in the quite crappy weather yesterday down the highway 55 going slow because of the bad weather. Then i noticed this gut wrenching smell what seems like it was coming from my engine bay? i smelled it worse when the heat was on after i smell that Im driving along at 55 and the thing just straight up dies hit the key nothin wouldent stay runnin. So with my better judgement i sadly saw my jeep getting towed for the first time. I got it home and tryed to start it. It will fire and seem like it wants to run but it shuts back down every time it gets up to about a grand almost like its not getting gas? So i hit the key again and put it to the floor revved up real high then it shut down? Now i was thinkin ya know mabey a fuel pump?? BUT this is where im confused i cant hear the fuel pump kick on and when i turn my accesories on, my radio,windshield wipers everything except my domelight WONT work the tac works i know that from when i put it to the floor. So im thinkin like did i fry the computer or what? please if anyone has any knowledge of How mabey why this happened and how i could fix it i would much appriciate it. I hate lookin outside and seeing a busted jeep.


Thealk3mist


Last edited by TheAlk3mist; 01-21-2011 at 11:54 AM..
TheAlk3mist is offline   Reply With Quote
Unread 01-21-2011, 12:33 PM   #2
dukie564
Registered User
1995 XJ Cherokee 
 
Join Date: Jun 2008
Location: Hanover, MD, Maryland
Posts: 2,722
It definitely sounds like an electrical issue. I'm not sure about the smell though can you describe it better?

You may indeed have fried your PCM (although i've never really heard of this happening). Take a look under the hood for anything that looks melted - primarily the power distribution center on the passenger side, and the PCM attached to the driver's side fender.
__________________
1995 XJ Cherokee Sport
4.5" Homebrew Lift, 4.0L HO I-6, AX-15, NP231, D30(Open)/C8.25(Locked)
33x12.5 Mickey Thompson Baja MTZ Tires, 283,000 mi and runnin' strong
http://www.jeepforum.com/forum/f22/project-danger-cart-xj-1297118/
dukie564 is offline   Reply With Quote
Unread 01-21-2011, 04:04 PM   #3
4ll4boutda4play
Registered User
1997 XJ Cherokee 
 
Join Date: Nov 2010
Location: Clayton, NM
Posts: 299
Another guess would be a burnt up lead to/from the battery/alternator maybe? never know when something will wear the insulation off and ground something out.. and that smell is horrible.
__________________
1997 Cherokee Sport, Rustys Intake with velocity stack and larger cone filter, Flowmaster 40 series, Junkyard Lift 3.5", Zone Nitro Shocks, Trimed fenders, 35x14.5x15 TSL Thornbirds (Looks HUGE) ... trail damage :) Future holds Aftermarket bumpers front and rear, exo cage, lockers/gears
4ll4boutda4play is offline   Reply With Quote
Unread 01-21-2011, 04:53 PM   #4
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota, MN
Posts: 8,399
Good advice above.

The smell and the fact that your Jeep died is most likely not coincidental.

Find what burned up and you likely have the root cause of why the vehicle won't run.
__________________
99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline   Reply With Quote
Unread 01-21-2011, 07:55 PM   #5
TheAlk3mist
Registered User
1995 XJ Cherokee 
 
Join Date: Jul 2010
Location: Butler PA
Posts: 26
hahaha belive it or not it was an ignition switch original from 95 i traced the problem it would run if i held it between acessories and start and me and my buddie rooted out it was the switch and what do ya know! completely burn like all hell and rooted out it was just from age! she still runs like a beast as for the horrible smell NO one and i mean no one wants to smell what hardened plastic burns like I'd give that old ignition some credit lasted 15 years cant ask for more than that thanks all for the advice!

~Thealk3mist~
TheAlk3mist is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.