99 XJ Sometimes won't start - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 99 XJ Sometimes won't start

Rough Country Deals at JeepHut.comSave at JeepHut on Smittybilt Soft topsUp to $75 Cash Back on Your ARB Fridge Freezer Purchase

Reply
Unread 05-15-2011, 02:11 PM   #16
Lukey
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2011
Location: Pittsburgh, PA
Posts: 42
Grrrr! Put the starter back in and it started right up. This is getting aggravating!!!

Lukey is offline   Reply With Quote
Unread 05-15-2011, 11:28 PM   #17
mspies1
Registered User
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: San diego
Posts: 187
Check the voltage between the battery and the fuse box ( the lead that goes to the front of the box under the little cover). Touch the negative side of the battery and the fuse box lead. The voltage should be the same over that as well as the battery. If its anything less you need a new cable. Do the same for the starter

I know a lot of ppl that have had the cable die. Make sure that all of the connections are clean using electric cleaner.

I know you have probably already have done this, but try and wiggle the wires around this time because it can have a short in the line and not know.

Hope this helps
__________________
RE 3.5 SF w/ adj arms, S-10 4" leafs, Front hitch, rear DIY bumper, 31" BFG ATs, D-Window w/ 4.5 BS
mspies1 is offline   Reply With Quote
Unread 05-20-2011, 05:44 PM   #18
Lukey
Registered User
1999 XJ Cherokee 
 
Join Date: Jan 2011
Location: Pittsburgh, PA
Posts: 42
Thanks everybody...

I just want to close the loop on this. We replaced the starter (it had a loose solenoid lead) and the ignition switch and it has taken care of this issue. I think the ignition switch was the culprit because the problem got worse after we put the new ignition lock cylinder in. So it makes sense that the switch it activates was also worn and was probably the reason it sometimes wouldn't fire up.
Lukey is offline   Reply With Quote
Unread 05-20-2011, 07:12 PM   #19
hxcjohnny
Registered User
2002 WJ 
 
Join Date: Jun 2008
Location: North Carolina
Posts: 561
edit. sorry, didnt read the entire post.
__________________
02 WJ Overland
hxcjohnny is offline   Reply With Quote
Unread 08-11-2013, 11:39 AM   #20
timnelly
Registered User
1999 XJ Cherokee 
 
Join Date: Aug 2013
Location: kenosha, Wisconsin
Posts: 6
I cannot get my xj to crank using the key, it cranks if i use power wire to starter but still wont start. Ground problem? Ignition problem?
timnelly is offline   Reply With Quote
Unread 08-11-2013, 06:39 PM   #21
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota, MN
Posts: 8,414
Quote:
Originally Posted by timnelly View Post
I cannot get my xj to crank using the key, it cranks if i use power wire to starter but still wont start. Ground problem? Ignition problem?
You're "hijacking" this thread. Start a new one.

It will give you more accurate replies and keep this thread on track. It gets confusing when more than one problem is being replied to.
__________________
99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.