99 xj 4.7 full time 4 cv axles replaced still tick - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 05-10-2013, 01:10 PM Thread Starter
1999gc_Laredo
Registered User
1999 XJ Cherokee 
 
Join Date: May 2013
Location: McCall
Posts: 1
99 xj 4.7 full time 4 cv axles replaced still tick

Title pretty much says it all. I replaced both cv axles as both were shot. Now it still ticks as I turn. And after I hit 10 mph its a constant. Did I get a bad axle? Or...? I am also looking at a bad front u joint on the front drive shaft. Would the u joint make the noise while turning? Please help! I only had her a month and put well over 300 just to get her to drive properly.

1999gc_Laredo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome