'99 starting issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 04-01-2011, 09:59 AM Thread Starter
topcat1
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2011
Location: Stafford
Posts: 6
'99 starting issue

My '99 has a problem starting every now and then. Turn the key and it sounds and feels like it wants to start, but it won't turn over. Turn the key again, hold it and it will fire up after about 5-10 seconds. ignition switch?

Sucks having 2 xj's with problems at the same time....

topcat1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-01-2011, 10:25 AM
XJH-007
Registered User
 
XJH-007's Avatar
 
Join Date: Mar 2005
Location: Morrison
Posts: 4,690
#1- Check and clean your battery terminals. Bad battery connection can cause your symptoms and much more strange issues.

Scott-Crawlorado Native
I have an addiction.....
*00' XJ_T-n-T Y-Link/6" RE_OME's_33" KM2's
Tera 4:1 / 4:56's_Elec. Locked D44
**84' CJ7 4"BDS 33's
***02 WJ Overland
XJH-007 is offline  
post #3 of 3 Old 04-01-2011, 10:27 AM
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota
Posts: 8,765
Garage
Agreed that connections and grounds need to be verified before looking elsewhere. Simple stuff first.

Remove battery cables, clean them and the battery posts until SHINY, and reattach.

99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Starting issue? Or not? Crunch XJ Cherokee Technical Forum 4 03-29-2010 03:13 PM
98 XJ 4.0 Starting Issue... rustedxj XJ Cherokee Technical Forum 3 09-21-2009 07:55 PM
89 2.5L starting issue whitebull72 MJ Comanche Technical Forum 1 08-19-2009 03:33 PM
Starting Issue Dannyboy18 XJ Cherokee Technical Forum 3 12-12-2008 08:14 AM
starting issue 89SAFARIXJ XJ Cherokee Technical Forum 9 09-15-2008 11:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome