99 jeep cherokee o2 sensor - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 04-10-2012, 04:10 PM Thread Starter
me77
Registered User
1999 XJ Cherokee 
 
Join Date: Apr 2012
Location: elktom
Posts: 5
99 jeep cherokee o2 sensor

My check engine light came on the other day and when we checked it, we got the p0141 code - oxygen sensor heater circuit bank 1 sensor 2. Does this mean my sensor is bad or the circuit involving the sensor has a problem. Also where exactly is the sensor located? I have a regular 99 jeep Cherokee with a 4.0L engine.

me77 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-10-2012, 04:18 PM
CJ7-Tim
Real Jeeps have dents
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis
Posts: 25,120
Possible causes
- Rear Heated Oxygen Sensor wire harness is short circuit or open circuit
- Rear Heated Oxygen Sensor wire connector poor electrical connection
- Faulty Rear Heated Oxygen Sensor
- Inappropriate fuel pressure
- Faulty fuel injectors
- Exhaust Manifold leaks

.

A recent Gallup public opinion poll shows the NRA, at 58% approval, has a higher approval rating than either Hillary Clinton or Barack Obama.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ...

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline  
post #3 of 6 Old 04-11-2012, 11:24 PM
Gutz88
Registered User
1997 XJ Cherokee 
 
Join Date: Mar 2012
Location: miami
Posts: 12
Yea check the wires.. I replaced mine to later find out this was the problem[/IMG]
Gutz88 is offline  
post #4 of 6 Old 04-11-2012, 11:25 PM
Gutz88
Registered User
1997 XJ Cherokee 
 
Join Date: Mar 2012
Location: miami
Posts: 12


Uploaded with ImageShack.us
Gutz88 is offline  
post #5 of 6 Old 04-14-2012, 03:11 PM
Dbiked
Registered User
1998 XJ Cherokee 
 
Join Date: Sep 2009
Location: Kaysville
Posts: 723
Where were those chafed at? Because I've got both O2 sensor circuits setting off my cel

Utah jeep crew member #32
Dbiked is offline  
post #6 of 6 Old 04-14-2012, 10:48 PM
Gutz88
Registered User
1997 XJ Cherokee 
 
Join Date: Mar 2012
Location: miami
Posts: 12
Thats the front one. I followed it to the top off engine. Thats right before it goes into the (main?) wire harness,,,
Also found that same thing on the wires coming from my MAP sensor..
Gutz88 is offline  
Reply

Tags
oxygen sensor , P0141

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
98 jeep cherokee sport rear o2 sensor? fozzies jeep XJ Cherokee Technical Forum 1 06-05-2011 08:32 PM
How do you get at a 4.7L 99 Jeep Grand Cherokee Limited 4 crankshaft position sensor SierraNev XJ Cherokee Technical Forum 2 12-22-2010 03:33 PM
97 Jeep Grand Cherokee CMP Sensor Location jeeperxj97 XJ Cherokee Technical Forum 1 10-02-2010 04:31 PM
How do change a cam sensor on 1999 jeep grand cherokee lowside XJ Cherokee Technical Forum 1 05-08-2010 02:04 PM
1999 Jeep Cherokee Battery Temperture Sensor ridebmxfbm XJ Cherokee Technical Forum 5 03-28-2010 10:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome