98 XJ Sputter on 2nd gear shift cold start? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 05-02-2013, 04:20 PM Thread Starter
SLOWPOKETAIL
Registered User
 
Join Date: Nov 2008
Location: Oxford
Posts: 11
98 XJ Sputter on 2nd gear shift cold start?

Hey guys, I have a 98 XJ w/ 212k on it. It's recently started giving me some trouble on the first start of the day where it seems like the engine is unable to give power to the transmission around 25mph (it wants to shift into 2nd but takes a minute), then after a few seconds it shifts and everything is fine. I have no idea what it could be. The engine seems to run strong, the transmission shifts/downshifts decently ones it's warmed up. The fluid is a clearish-brown color (I know, that's not good)

I'm also debating whether I should pick up another Cherokee instead of putting time and money into this one (it needs a new trackbar, steering stab., shocks and struts, possible trans?, front bumper, rockers, muffler, cat. converter if I don't decide to straight pipe it..)

Can anyone give me some insight on this?

SLOWPOKETAIL is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome