98 Cherokee Runs terrible cold but good warm - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 09-28-2011, 02:57 PM Thread Starter
officialvin
Registered User
 
Join Date: Dec 2006
Location: nj
Posts: 33
98 Cherokee Runs terrible cold but good warm

Hey. My cherokee runs terrible when i first start it up, it misses and sometimes stalls. it smells like its running very rich also. Once it warms up to 210 it runs pretty much perfect.. I had an issue with it randomly running bad while driving and idling and i replaced the upper o2 sensor and it was fine. about 2 days later this problem started. I have replaced the TPS IACV Air temp sensor in the intake.. Im thinking it may be the ECTS but my temp gauge works fine so im not sure.. also plugs wires cap and rotor are pretty new. Anyone have any ideas? thanks in advance

officialvin is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-28-2011, 03:05 PM
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota
Posts: 8,767
Garage
Have you put a scan tool or a code reader on to see if you have any stored codes?

99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
runs great cold but when warm it runs bad. flaneryjunior99 XJ Cherokee Technical Forum 4 07-09-2011 06:29 PM
cold start good idle - engine gets warm and low idle ahuf XJ Cherokee Technical Forum 9 01-30-2011 04:17 PM
New member can use a little help. XJ runs warm? mula XJ Cherokee Technical Forum 19 12-12-2010 08:27 AM
AC cold 10 minutes, warm 20, cold 10... js5278 XJ Cherokee Technical Forum 9 06-18-2010 03:56 PM
Runs rough when warm, help Hendo_10 XJ Cherokee Technical Forum 4 01-03-2006 03:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome