97 cherokee sport won't start - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 19 Old 12-06-2013, 04:27 PM Thread Starter
Mushu1431
Registered User
 
Join Date: Dec 2013
Location: Osceola
Posts: 8
97 cherokee sport won't start

97 cherokee has spark has fuel at the rail replaced cps still nothing. I noticed that if I prop the throttle open all the way it tries to start like it wants to pop off but won't, it won't start with starting fluid either, all the gauges work no check engine light good compression, giving me a headache! Help please!

Mushu1431 is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 12-06-2013, 04:32 PM Thread Starter
Mushu1431
Registered User
 
Join Date: Dec 2013
Location: Osceola
Posts: 8
Oh and it's a sport 4.0
Mushu1431 is offline  
post #3 of 19 Old 12-06-2013, 04:40 PM
CJ7-Tim
Real Jeeps have dents
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis
Posts: 24,877
Are all the tune-up parts fresh ? Have you tested the fuel pressure ? Did you try numerous times to start the engine and flood it ? How old is the battery ?

.

A recent Gallup public opinion poll shows the NRA, at 58% approval, has a higher approval rating than either Hillary Clinton or Barack Obama.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ...

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline  
post #4 of 19 Old 12-06-2013, 04:42 PM
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota
Posts: 8,753
Garage
You mentioned it has spark, but does it have GOOD spark. You must have a snapping, BLUE spark to start the engine. White/orange/yellow indicates a weak spark which is not likely going to start the engine.

A weak spark is usually caused by a faulty ignition coil. The coil can be tested for both primary and secondary resistances with a manual and a meter.

Good luck and keep us udpated!

99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline  
post #5 of 19 Old 12-06-2013, 04:45 PM Thread Starter
Mushu1431
Registered User
 
Join Date: Dec 2013
Location: Osceola
Posts: 8
All new cap rotor plugs wires coil pickup plate, pulled all the plugs out and cranked it around to blow out any fuel, starting fluid in the cylinders, haven't checked fuel pressure yet but I pushed the needle in on fuel rail and sprayed out really good
Mushu1431 is offline  
post #6 of 19 Old 12-06-2013, 05:03 PM
Sycoglitch
Registered User
2001 XJ Cherokee 
 
Join Date: Apr 2011
Location: Staten island
Posts: 84
So you go to start the jeep. You turn the key and you hear the engine crank correct? And it only turns over with your foot on the gas peddle or it never turns over. Possible TPS issue

Sent from the jeep cause my owner is drunk again

01' Limited I6, C8.25, D30, NP231, 3" Zone AAL Lift, Extended Shackles and relocators, Hella H4 E-code headlights w/ HD Wiring Harness, Fully Swayless, Front JKS Disco'd when needed, 60mm Bored TB, IRO LCA, Rear Disc Conversion
Sycoglitch is offline  
post #7 of 19 Old 12-06-2013, 05:14 PM Thread Starter
Mushu1431
Registered User
 
Join Date: Dec 2013
Location: Osceola
Posts: 8
yeah cranks over fine
Mushu1431 is offline  
post #8 of 19 Old 12-06-2013, 05:15 PM
Sycoglitch
Registered User
2001 XJ Cherokee 
 
Join Date: Apr 2011
Location: Staten island
Posts: 84
Quote:
Originally Posted by Mushu1431
yeah cranks over fine
It cranks just doesn't turn over. And when you put your foot on the gas she turns over?

Sent from the jeep cause my owner is drunk again

01' Limited I6, C8.25, D30, NP231, 3" Zone AAL Lift, Extended Shackles and relocators, Hella H4 E-code headlights w/ HD Wiring Harness, Fully Swayless, Front JKS Disco'd when needed, 60mm Bored TB, IRO LCA, Rear Disc Conversion
Sycoglitch is offline  
post #9 of 19 Old 12-06-2013, 05:26 PM Thread Starter
Mushu1431
Registered User
 
Join Date: Dec 2013
Location: Osceola
Posts: 8
spark wasn't blue.
Mushu1431 is offline  
post #10 of 19 Old 12-06-2013, 05:30 PM Thread Starter
Mushu1431
Registered User
 
Join Date: Dec 2013
Location: Osceola
Posts: 8
wont run at all, if I crank it with the gas pedal all the way to the floor it huffs n puffs like its about to turn over. if I try and crank it without the pedal down it just cranks
Mushu1431 is offline  
post #11 of 19 Old 12-07-2013, 03:33 AM
oakmckinley
Registered User
1999 TJ Wrangler 
 
Join Date: Mar 2010
Location: Minneapolis
Posts: 1,623
I am sure someone will correct me if I am wrong but when you hold the pedal to the floor you are cutting off the fuel pump. On the old carb vehicles you used to have to do this when they flooded.
Pull the plugs and let it air out overnight. It's probably so wet in there that's why it won't start. I have never sprayed starting fluid in the cylinders directly, you should only need to spray it in the air inlet.

Sent from my iPad using JeepForum

1999 TJ
2000 XJ Cherokee
2010 Mustang
1964 Ford Fairlane 500
oakmckinley is offline  
post #12 of 19 Old 12-07-2013, 06:50 AM
Sycoglitch
Registered User
2001 XJ Cherokee 
 
Join Date: Apr 2011
Location: Staten island
Posts: 84
Wait have you had the battery load tested to? A don't just replace the TPS. There should be a write up either here or on cherokee forum about testing with a multi meter

01' Limited I6, C8.25, D30, NP231, 3" Zone AAL Lift, Extended Shackles and relocators, Hella H4 E-code headlights w/ HD Wiring Harness, Fully Swayless, Front JKS Disco'd when needed, 60mm Bored TB, IRO LCA, Rear Disc Conversion
Sycoglitch is offline  
post #13 of 19 Old 12-07-2013, 08:56 AM Thread Starter
Mushu1431
Registered User
 
Join Date: Dec 2013
Location: Osceola
Posts: 8
battery is only 4 months old
Mushu1431 is offline  
post #14 of 19 Old 12-07-2013, 09:20 AM
Sycoglitch
Registered User
2001 XJ Cherokee 
 
Join Date: Apr 2011
Location: Staten island
Posts: 84
Quote:
Originally Posted by Mushu1431 View Post
battery is only 4 months old
Im giving you the easy free things to check.still do it. Another free thing to try it this.

Get in jeep. Turn key to accesory. Don't start. Turn key off. Turn to accesory again. Let the fuel pump prime three times. After that then start. If jeep starts you may have a bad check valve. These are the free things to check. Im still leaning towards TPS so test that

01' Limited I6, C8.25, D30, NP231, 3" Zone AAL Lift, Extended Shackles and relocators, Hella H4 E-code headlights w/ HD Wiring Harness, Fully Swayless, Front JKS Disco'd when needed, 60mm Bored TB, IRO LCA, Rear Disc Conversion
Sycoglitch is offline  
post #15 of 19 Old 12-07-2013, 01:16 PM Thread Starter
Mushu1431
Registered User
 
Join Date: Dec 2013
Location: Osceola
Posts: 8
Tried the prime the fuel pump, didn't work. Put a new coil on still nothing, pulled plugs all have a little gas on them, aahhh! About to pull some hair out
Mushu1431 is offline  
Reply

Tags
fuel , spark , won't start

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome