96 xj ho 6 4x4 starting problems - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 05-29-2014, 09:16 PM Thread Starter
cchambless13
Registered User
 
Join Date: Dec 2013
Location: summerville
Posts: 3
96 xj ho 6 4x4 starting problems

So here goes, key ignition switch snapped I had to hot wire it to get it home, then my gf had to drive to work next thing I know it's 4 months later before I break down and get the key switch problem is it was too late, I f ed it up by hard wiring it for so long. I got the new key In , guess what no start had burnt wires under the steering column fixed those, got voltage to all the things that need the voltage starter ASD ect , I checked coil replaced it bc low voltage was read, I got voltage, put it into the cap did t get it out replaced w new button and cap, still nothing. New battery to be sure still now no spark, I've read all the forums I think on this ASD, CPA, ECt I'm looking at a new distributor now. I've tried the alarm trick resetting the ecu, disconnecting and resetting the CPs, is there anything else that I'm missing ??? It's driving me nuts. I've checked tps, CPA, timing, rotor button moving, starter, 5volt reference on all the sensors so I think computer is still good, is there an easy way to test the ecu? I even loosened the screws to make sure they were the 1/4" screws not the 1/2" screws that sometimes cause issues.

So my to do list:
All new ASD style relays

Camshaft position sensor/stator/gen replacement

Check alternator( jic) for gen light

Crankshaft position sensor replacement

Computer

My ASD relay is clicking and fuel pump clicks w it along w all fuel Injectors
I'd say about every 3 seconds they click over and over again as if they r all resetting over and over again.

Let me know if anyone can help me please I'm n the charleston area and tight on funds

cchambless13 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-29-2014, 09:56 PM Thread Starter
cchambless13
Registered User
 
Join Date: Dec 2013
Location: summerville
Posts: 3
Ok my gf just found something ! The camshaft position sensor after key on sends a signal to the e c u then goes to the ASD relay causing clicking if there is low voltage. That in turn will keep everything from working the crankshaft fuel Injectors spark fuel pump etc . So next on my list is the pickup that goes in the distributor. I looked at mine a few hours before and with the jeep having 207k miles on it it is worn down pretty bad. So that's next on the todo list and of course ASD relay lol. Thanks guys hopes this helps everybody
cchambless13 is offline  
Reply

Tags
asd , cps , distributor , ignition

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome