96 cherokee just died... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 96 cherokee just died...

Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits BLACK FRIDAY SPECIALS!! You asked, we deliver!Rough Country Lift Kits and Parts!

Reply
Unread 12-30-2009, 08:42 PM   #1
dustydoesit
Registered User
1996 FSJ Cherokee 
 
Join Date: Dec 2009
Location: wisconsin
Posts: 19
96 cherokee just died...

my Cherokee died half a block from my house, i have good fuel pressure, 3/4 inch spark at all cylinders, fuel injectors are working ...it cranks but wont fire at all i get a pop once in awhile but nothing more. coil,distributer,cap rotor, plugs and wires are new. new crank sensor. fuel filter is new, fuel pump is working. what else is there? besides valve timing? ignition timing is controlled by pcm and is timed right...maybe valve timing and ignition timing aren't matching? timing chain is not broken. maybe jumped time? charging system, battery, starter, alternator, and cables are all new as well. the battery is strong. i know this jeep inside out but i'm stumped... any ideas?


Last edited by dustydoesit; 12-30-2009 at 08:52 PM..
dustydoesit is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 08:46 PM   #2
m_amilli
Registered User
1996 ZJ 
 
Join Date: Dec 2009
Location: phx. az
Posts: 53
My Jeep Did The Same Thing.. I Changed All That Stuff And It Came To Be A Short In The Wire Coming Out The Tranny.. In The Middle Of Your Jeep Underneath Check To See If A Clip Or A Zip Tie Came Off Your Wires By The Tranny Maybe A Chopped Wire Like Mine
m_amilli is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 09:08 PM   #3
dustydoesit
Registered User
1996 FSJ Cherokee 
 
Join Date: Dec 2009
Location: wisconsin
Posts: 19
are you talkin about the crank sensor? it's new, or maybe a ground wire? or are you talkin about the 02 sensor on the cat?
dustydoesit is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 09:14 PM   #4
m_amilli
Registered User
1996 ZJ 
 
Join Date: Dec 2009
Location: phx. az
Posts: 53
its by the cat.. i dont know much about what parts are called but def not the crank sensor.. not by the bell housing
m_amilli is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 09:15 PM   #5
m_amilli
Registered User
1996 ZJ 
 
Join Date: Dec 2009
Location: phx. az
Posts: 53
by the thing that spins when you drive underneath
m_amilli is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 09:21 PM   #6
dustydoesit
Registered User
1996 FSJ Cherokee 
 
Join Date: Dec 2009
Location: wisconsin
Posts: 19
sounds about right to be the 02 sensor but it's only 6 months old and that would only cause erratic idle..
dustydoesit is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 09:29 PM   #7
m_amilli
Registered User
1996 ZJ 
 
Join Date: Dec 2009
Location: phx. az
Posts: 53
it connects to the middle of the tranny tho
m_amilli is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 09:43 PM   #8
dustydoesit
Registered User
1996 FSJ Cherokee 
 
Join Date: Dec 2009
Location: wisconsin
Posts: 19
i'm gonna have to check that out...
dustydoesit is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 09:44 PM   #9
dustydoesit
Registered User
1996 FSJ Cherokee 
 
Join Date: Dec 2009
Location: wisconsin
Posts: 19
not the neutral start switch?
dustydoesit is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 09:55 PM   #10
m_amilli
Registered User
1996 ZJ 
 
Join Date: Dec 2009
Location: phx. az
Posts: 53
nope it is 3 wires that come off the middle of ur tranny
m_amilli is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 10:05 PM   #11
kzjim
Registered User
1996 XJ Cherokee 
 
Join Date: Oct 2006
Location: West Covina, CA
Posts: 198
Cam position sensor maybe?
__________________
"Those who hammer their guns into plows will plow for those who do not"...Thomas Jefferson

"Beware lest the Stone Age return on the gleaming wings of science." - Winston Churchill
kzjim is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 10:09 PM   #12
m_amilli
Registered User
1996 ZJ 
 
Join Date: Dec 2009
Location: phx. az
Posts: 53
srry if i couldn help dude.. i had the same prob
m_amilli is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 10:11 PM   #13
dustydoesit
Registered User
1996 FSJ Cherokee 
 
Join Date: Dec 2009
Location: wisconsin
Posts: 19
no cam sensor on 96 cherokee. only crank and thats on top of the tranny by the flywheel.it has three wires but i changed that already ..
dustydoesit is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 10:22 PM   #14
oderalxjlaredo
Registered User
2000 XJ Cherokee 
 
Join Date: Aug 2009
Location: Fairfax, VA
Posts: 395
Quote:
Originally Posted by m_amilli View Post
by the thing that spins when you drive underneath
You're about to get sigged, my friend.


As the for OP, maybe check the connector at your computer and ensure all the wires going to it are good.

I know you said it's new, but I would also test the crank position sensor, and make sure the rotor in the distributor is properly oriented. Assuming you have an automatic, will it try to start in neutral?

That's the best I've got for now.
oderalxjlaredo is offline   Reply With Quote Quick reply to this message
Unread 12-30-2009, 10:33 PM   #15
offroadnut36
Registered User
1990 XJ Cherokee 
 
Join Date: Sep 2009
Location: Blairsville, PA
Posts: 202
maybe a bad negative batt. terminal ground. when it pops do all the electronics go out, then come back on after a while?
offroadnut36 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.