95 cherokee sport gas and spedometer gauges not working - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 10-26-2008, 09:07 AM Thread Starter
skierdude52689
Registered User
1997 XJ Cherokee 
 
Join Date: Sep 2007
Location: Lyndonville
Posts: 63
95 cherokee sport gas and spedometer gauges not working

for a like 2 weeks my spedometer would randomly go up and down when i hit bumps the needle would go up and down and then return to the regular speed it was at. now the gas and speed don't work at all. i only have a speedomete and gas gauge, nothing else.

my question, whats the problem, what's the cheapest way to fix it.
*edit* i checked the fuse box and the fuse for the gauges *number 17* is fine, checked continuity and it works. so maybe a ground?


Last edited by skierdude52689; 10-26-2008 at 10:28 AM.
skierdude52689 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 10-26-2008, 10:30 AM
STG
Registered User
2006 WK 
 
Join Date: Oct 2008
Location: San Antonio
Posts: 61
Good question...my gauges have been going haywire lately, too - but with me it's the oil pressure and engine temp gauges. I think the issue is a ground in mine, but I've not yet checked.
STG is offline  
post #3 of 7 Old 10-26-2008, 11:10 PM Thread Starter
skierdude52689
Registered User
1997 XJ Cherokee 
 
Join Date: Sep 2007
Location: Lyndonville
Posts: 63
*edit* the check engine light just turned on as well as the battery light, checked all fuses and there all good. its a new battery as of a year and a half ago.

seriously any help would be great!
skierdude52689 is offline  
post #4 of 7 Old 10-27-2008, 03:56 PM
xjcowboy01
Registered User
2001 XJ Cherokee 
 
Join Date: Mar 2008
Location: Albuquerque
Posts: 409
Hey man I had a problem with the gauges on my 93 and it turned out to be ground wires. On the passenger side of the engine and just behind the distributor is where they are. There are three of them in total and they all control your gauges. Fix all those wires and you should be good to go. That would also explain the intermittence of the problem. The wires probably werent broken all the way at first but now they are. Give it a shot.

Live for those who have died for your freedom.
xjcowboy01 is offline  
post #5 of 7 Old 10-27-2008, 09:41 PM
scruff_08
Registered User
1996 XJ Cherokee 
 
Join Date: Oct 2008
Location: Pa
Posts: 9
I had a problem on my '96 that the fuse were good but the fuse panel itself was melted on the back, you could barely tell but if you looked at the socket for the gauge fuses it was burnt out and would only work occasionally
scruff_08 is offline  
post #6 of 7 Old 10-28-2008, 12:18 PM
warrior_oh58d
Registered User
1991 XJ Cherokee 
 
Join Date: Jun 2008
Location: Raleigh, NC
Posts: 135
I'm having a similar problem on my '91 but none of my guages are working at all, i am also getting some crazy hesitation on start up, it seems to get better when the engine warms up but now it's doing it all the way through the drive to wherever i'm going
warrior_oh58d is offline  
post #7 of 7 Old 10-28-2008, 01:59 PM
iflyabeech
Registered User
 
iflyabeech's Avatar
1999 XJ Cherokee 
 
Join Date: May 2003
Location: Corpus Christi, Texas
Posts: 252
try moving the wire bundles above your feet/under the steering wheel. I have had a problem of all my gauges going to zero intermittently for a while. usually a kick under the dash and they come back to life...i have no idea what is coming loose under there, but a little kick or two does the trick....I update my 99 XJ gauges from the idiot lights to mechanical gauges and now when this happens, I get "No Bus" on the odometer...I am not sure if this is your problem in the 95 or not, but thought it might help.....you can also do a forum search on this!

1999 XJ Cherokee SE 4dr 4x4
4.0L I6, AX15 5-Speed Tranny, NP231, Dana 30 high pinion Front, Chrysler 8.25 Rear, 3.07 gears, Quadretec HD leaf springs

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
iflyabeech is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Gauges Working Intermittently - 1997 Cherokee jrennard3 XJ Cherokee Technical Forum 4 12-02-2014 06:51 PM
99 Cherokee Sport 4.0L - All gauges failure searcherrr XJ Cherokee Technical Forum 6 07-02-2013 06:02 PM
96 Grand Cherokee Limited - no gauges working harryash XJ Cherokee Technical Forum 1 02-06-2010 05:05 PM
1992 cherokee laredo speed/tach/fuel gauges not working? ChucksJeep XJ Cherokee Technical Forum 0 02-24-2008 09:12 AM
97 Cherokee Sport - passenger window not working pharunk XJ Cherokee Technical Forum 2 01-14-2008 05:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome