95 cherokee sport gas and spedometer gauges not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 95 cherokee sport gas and spedometer gauges not working

RIGID LED Light Blowout Sale - All Sizes, All Series, all Stainless Steel Door Hinge PinsPoly Door Hinge Bushings

Reply
Unread 10-26-2008, 08:07 AM   #1
skierdude52689
Registered User
1997 XJ Cherokee 
 
Join Date: Sep 2007
Location: Lyndonville, VT
Posts: 63
95 cherokee sport gas and spedometer gauges not working

for a like 2 weeks my spedometer would randomly go up and down when i hit bumps the needle would go up and down and then return to the regular speed it was at. now the gas and speed don't work at all. i only have a speedomete and gas gauge, nothing else.

my question, whats the problem, what's the cheapest way to fix it.
*edit* i checked the fuse box and the fuse for the gauges *number 17* is fine, checked continuity and it works. so maybe a ground?


Last edited by skierdude52689; 10-26-2008 at 09:28 AM..
skierdude52689 is offline   Reply With Quote
Unread 10-26-2008, 09:30 AM   #2
STG
Registered User
2006 WK 
 
Join Date: Oct 2008
Location: San Antonio
Posts: 61
Good question...my gauges have been going haywire lately, too - but with me it's the oil pressure and engine temp gauges. I think the issue is a ground in mine, but I've not yet checked.
STG is offline   Reply With Quote
Unread 10-26-2008, 10:10 PM   #3
skierdude52689
Registered User
1997 XJ Cherokee 
 
Join Date: Sep 2007
Location: Lyndonville, VT
Posts: 63
*edit* the check engine light just turned on as well as the battery light, checked all fuses and there all good. its a new battery as of a year and a half ago.

seriously any help would be great!
skierdude52689 is offline   Reply With Quote
Unread 10-27-2008, 02:56 PM   #4
xjcowboy01
Registered User
2001 XJ Cherokee 
 
Join Date: Mar 2008
Location: Albuquerque
Posts: 409
Hey man I had a problem with the gauges on my 93 and it turned out to be ground wires. On the passenger side of the engine and just behind the distributor is where they are. There are three of them in total and they all control your gauges. Fix all those wires and you should be good to go. That would also explain the intermittence of the problem. The wires probably werent broken all the way at first but now they are. Give it a shot.
__________________
Live for those who have died for your freedom.
xjcowboy01 is offline   Reply With Quote
Unread 10-27-2008, 08:41 PM   #5
scruff_08
Registered User
1996 XJ Cherokee 
 
Join Date: Oct 2008
Location: Pa
Posts: 9
I had a problem on my '96 that the fuse were good but the fuse panel itself was melted on the back, you could barely tell but if you looked at the socket for the gauge fuses it was burnt out and would only work occasionally
scruff_08 is offline   Reply With Quote
Unread 10-28-2008, 11:18 AM   #6
warrior_oh58d
Registered User
1991 XJ Cherokee 
 
Join Date: Jun 2008
Location: Raleigh, NC
Posts: 135
I'm having a similar problem on my '91 but none of my guages are working at all, i am also getting some crazy hesitation on start up, it seems to get better when the engine warms up but now it's doing it all the way through the drive to wherever i'm going
warrior_oh58d is offline   Reply With Quote
Unread 10-28-2008, 12:59 PM   #7
iflyabeech
Registered User
1999 XJ Cherokee 
 
Join Date: May 2003
Location: Corpus Christi, Texas
Posts: 252
try moving the wire bundles above your feet/under the steering wheel. I have had a problem of all my gauges going to zero intermittently for a while. usually a kick under the dash and they come back to life...i have no idea what is coming loose under there, but a little kick or two does the trick....I update my 99 XJ gauges from the idiot lights to mechanical gauges and now when this happens, I get "No Bus" on the odometer...I am not sure if this is your problem in the 95 or not, but thought it might help.....you can also do a forum search on this!
__________________
1999 XJ Cherokee SE 4dr 4x4
4.0L I6, AX15 5-Speed Tranny, NP231, Dana 30 high pinion Front, Chrysler 8.25 Rear, 3.07 gears, Quadretec HD leaf springs
http://www.thirdcoastoutdoors.com
iflyabeech is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.