94 XJ - No start!!! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 05-17-2012, 10:32 AM Thread Starter
gwb16
Registered User
1994 XJ Cherokee 
 
Join Date: Mar 2011
Location: Smithfield
Posts: 7
94 XJ - No start!!!

OK - First, thanks in advance for any help that some of you more seasoned guru's may be able to send me!

Quick run down, 94 XJ, 4.0L....just replaced the battery today, it was due <5 years old. Previously replaced the alternator and starter, within the last couple of days. Hit the key and all I get is a big "click", sounds like the starter solenoid engaging, but she isn't turning over. Fresh charge on the battery. For grins and giggles, I attempted to jump start it...still only getting the "click"....I'm thinking I probably have a battery cable "issue". Anyone agree or disagree with me? Advice? Suggestions? I'm all ears at this point! She has 215K miles on it and still runs like a champ....when it was starting! LOL!

gwb16 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-17-2012, 11:12 AM
Saudade
Registered User
1988 XJ Cherokee 
 
Join Date: Jun 2008
Location: SoCal
Posts: 1,390
Check your grounds. Peel back some of the insulation from both battery cables and see if there's a lot of corrosion.
Saudade is offline  
post #3 of 7 Old 05-17-2012, 11:34 AM
Armycherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Apr 2012
Location: Athens
Posts: 253
X2 sounds like a bad connection
Armycherokee is offline  
post #4 of 7 Old 05-17-2012, 01:46 PM Thread Starter
gwb16
Registered User
1994 XJ Cherokee 
 
Join Date: Mar 2011
Location: Smithfield
Posts: 7
Thanks! I'll give it a whirl when I get home this evening!
gwb16 is offline  
post #5 of 7 Old 05-17-2012, 01:51 PM
MoparXJ
Registered User
1993 XJ Cherokee 
 
Join Date: Mar 2012
Location: El Paso
Posts: 44
Try dropping into neutral and turning everything, simple way to eliminate one problem
MoparXJ is offline  
post #6 of 7 Old 05-17-2012, 02:52 PM Thread Starter
gwb16
Registered User
1994 XJ Cherokee 
 
Join Date: Mar 2011
Location: Smithfield
Posts: 7
Quote:
Originally Posted by MoparXJ View Post
Try dropping into neutral and turning everything, simple way to eliminate one problem
I just had my son go turn the headlights on - NOTHING! But, he said the seatbelt buzzer was going off when he turned the key on and the radio was playing...this thing is going to drive me crazy before it's over - LOL!

Starter relay gone bad?
gwb16 is offline  
post #7 of 7 Old 05-18-2012, 05:14 AM Thread Starter
gwb16
Registered User
1994 XJ Cherokee 
 
Join Date: Mar 2011
Location: Smithfield
Posts: 7
It was the battery cables. I skinned back a short portion of insulation and it clearly had green oxidation, the negative cable didn't but I changed them all. She fired right up.

The alternator needed to be replaced (it bench tested bad), the starter probably didn't need to be, but it's new now, so I'm going to keep the old one as a spare.

Thanks again for the input!
gwb16 is offline  
Reply

Tags
alternator , battery , starter , starting issue

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
1998 XJ Won't start on 1st try, fires right up on 2nd attempt / slow start spenceuiuc XJ Cherokee Technical Forum 18 08-06-2012 06:26 AM
No start......Replaced the Crank Sensor and still no start, Whats UP? batilzown XJ Cherokee Technical Forum 3 02-17-2010 12:50 PM
electric start prob. jeep wont start blackl4life XJ Cherokee Technical Forum 1 08-21-2009 08:56 AM
interesting hard start/no start/dead battery problem TXjeep97 XJ Cherokee Technical Forum 4 02-18-2008 08:18 PM
Eh.. start? no start? roll the dice? jiggle the cable? UnderDog! XJ Cherokee Technical Forum 6 05-25-2006 09:14 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome