94 XJ - No start!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 94 XJ - No start!!!

Building a Bumper?Ruffstuff Axle Simple Swap Kit!~Artec JK 1 TON SWAP~

Reply
Unread 05-17-2012, 10:32 AM   #1
gwb16
Registered User
1994 XJ Cherokee 
 
Join Date: Mar 2011
Location: Smithfield, VA
Posts: 7
94 XJ - No start!!!

OK - First, thanks in advance for any help that some of you more seasoned guru's may be able to send me!

Quick run down, 94 XJ, 4.0L....just replaced the battery today, it was due <5 years old. Previously replaced the alternator and starter, within the last couple of days. Hit the key and all I get is a big "click", sounds like the starter solenoid engaging, but she isn't turning over. Fresh charge on the battery. For grins and giggles, I attempted to jump start it...still only getting the "click"....I'm thinking I probably have a battery cable "issue". Anyone agree or disagree with me? Advice? Suggestions? I'm all ears at this point! She has 215K miles on it and still runs like a champ....when it was starting! LOL!

gwb16 is offline   Reply With Quote
Unread 05-17-2012, 11:12 AM   #2
Saudade
Registered User
1988 XJ Cherokee 
 
Join Date: Jun 2008
Location: SoCal
Posts: 1,378
Check your grounds. Peel back some of the insulation from both battery cables and see if there's a lot of corrosion.
Saudade is offline   Reply With Quote
Unread 05-17-2012, 11:34 AM   #3
Armycherokee
Registered User
1992 XJ Cherokee 
 
Join Date: Apr 2012
Location: Athens, Alabama
Posts: 253
X2 sounds like a bad connection
Armycherokee is offline   Reply With Quote
Unread 05-17-2012, 01:46 PM   #4
gwb16
Registered User
1994 XJ Cherokee 
 
Join Date: Mar 2011
Location: Smithfield, VA
Posts: 7
Thanks! I'll give it a whirl when I get home this evening!
gwb16 is offline   Reply With Quote
Unread 05-17-2012, 01:51 PM   #5
MoparXJ
Registered User
1993 XJ Cherokee 
 
Join Date: Mar 2012
Location: El Paso, Texas
Posts: 44
Try dropping into neutral and turning everything, simple way to eliminate one problem
MoparXJ is offline   Reply With Quote
Unread 05-17-2012, 02:52 PM   #6
gwb16
Registered User
1994 XJ Cherokee 
 
Join Date: Mar 2011
Location: Smithfield, VA
Posts: 7
Quote:
Originally Posted by MoparXJ View Post
Try dropping into neutral and turning everything, simple way to eliminate one problem
I just had my son go turn the headlights on - NOTHING! But, he said the seatbelt buzzer was going off when he turned the key on and the radio was playing...this thing is going to drive me crazy before it's over - LOL!

Starter relay gone bad?
gwb16 is offline   Reply With Quote
Unread 05-18-2012, 05:14 AM   #7
gwb16
Registered User
1994 XJ Cherokee 
 
Join Date: Mar 2011
Location: Smithfield, VA
Posts: 7
It was the battery cables. I skinned back a short portion of insulation and it clearly had green oxidation, the negative cable didn't but I changed them all. She fired right up.

The alternator needed to be replaced (it bench tested bad), the starter probably didn't need to be, but it's new now, so I'm going to keep the old one as a spare.

Thanks again for the input!
gwb16 is offline   Reply With Quote
Reply

Tags
alternator , battery , starter , starting issue
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.