90 xj oil pressure sending unit help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 90 xj oil pressure sending unit help

Baseline 4x4 Lifetime Warranty 4340 Chromoly Axle Shaft KiClayton Off Road WJ Long Arm Kits!Clayton Off Road - JK Prototype Gas Tank Skid

Reply
Unread 08-01-2013, 03:42 AM   #1
Elrod90xj
Registered User
1990 XJ Cherokee 
 
Join Date: Jul 2013
Location: Rapid City, SD
Posts: 18
90 xj oil pressure sending unit help

So i was reading on some forums on here and alot of people say that their oil pressure sending unit was leaking oil. So i went to check mine out, it had a little oil on it but the wire coming out was hanging there not connected to anything! I looked all around the area and could not find any other disconnected wires. Does anybody know where the wire goes to from the unit? i was having problems with my oil gauge, and I think i might have found the problem. Now if i can just figure out where the wire needs to be reconnected I will be golden. Thanks!

Elrod90xj is offline   Reply With Quote
Unread 08-02-2013, 07:58 PM   #2
Mywrangler94
Registered User
1994 YJ Wrangler 
 
Join Date: Nov 2010
Location: Staten Island, New York
Posts: 443
The reason you can't find the other end of that wire is because it goes into the wire loom.....you know that nice plastic covering over all those wires. Makes it look nice and neat...I would not doubt that its broken in there...
Mywrangler94 is offline   Reply With Quote
Unread 08-04-2013, 01:07 AM   #3
Elrod90xj
Registered User
1990 XJ Cherokee 
 
Join Date: Jul 2013
Location: Rapid City, SD
Posts: 18
Quote:
Originally Posted by Mywrangler94 View Post
The reason you can't find the other end of that wire is because it goes into the wire loom.....you know that nice plastic covering over all those wires. Makes it look nice and neat...I would not doubt that its broken in there...
Is it just one wire running straight from the back of the gauge to the unit? If so, can't I just run a new wire from the gauge to the unit to avoid digging through all those looms?
Elrod90xj is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.