89 xj 4.0 misfire - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 09-21-2011, 06:13 PM Thread Starter
Dsickness691
Registered User
1991 XJ Cherokee 
 
Join Date: Jun 2011
Location: Virginia beach
Posts: 13
89 xj 4.0 misfire

Okay well today, i went out to re tighten my intake manifold bolts since it seemed to be idling high. I just did this a few months ago and dont drive it very often, the back half of bolts where all loose again with the very back one being able to be tightend with your fingers. When i started it back up, it was misfiring and wont stop. I know i have a very frayed cps sensor cable that when i move it, causes the jeep to cut off. Could this be my problem? It did this the last time i tigthend up the bolts but cleared up. A freind doing body work on it for me, also adjusted my idle screw without me knowing because it was idling high due to the intake being loose. I have a few broken vaccum lines as well but the jeep has run fine since i bought it like that. Any ideas? All answers are greatly apreciated

Dsickness691 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-21-2011, 07:11 PM
FleshEater
Registered User
2014 JK Wrangler 
 
Join Date: Dec 2010
Location: Hell
Posts: 2,495
My XJ had a miss right around 2500 RPM's but once I hooked up all the proper vacuum lines it disappeared. Did you start in the middle of your manifold and tighten your bolts outward going top to bottom? Replace the broken cable as well...if all of these issues don't fix it then there is something else wrong.

2014 JKU Rubicon *DAILY DRIVER*
Gone but not forgotten; 2005 LJ *SOLD* 1987 XJ *SOLD* 2002 WJ *SOLD* 1995 ZJ *SOLD*
FleshEater is offline  
post #3 of 3 Old 09-21-2011, 07:28 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,065
Fix the vacuum lines and the CPS wiring as they are known problems. Why look elsewhere first?
cruiser54 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
misfire , ive done almost everything aleydic XJ Cherokee Technical Forum 44 01-18-2011 10:06 AM
misfire 1 and 3 toates89 XJ Cherokee Technical Forum 4 01-10-2011 05:16 PM
4.0 CEL, random cylinder misfire, cyl 2/5 misfire, and a loud engine noise at accel. Aran XJ Cherokee Technical Forum 13 03-17-2009 06:22 AM
Misfire cherokeeracer XJ Cherokee Technical Forum 0 06-25-2008 08:08 PM
Misfire...help!!! Paul Courbot XJ Cherokee Technical Forum 3 08-02-2006 11:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome