89 4.0 XJ so weak I can't use 5th gear - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 89 4.0 XJ so weak I can't use 5th gear

Halloween Savings to die for!Offset Tie Rod Kit From RuffStuff!Ruffstuff Axle Simple Swap Kit!

Reply
Unread 03-21-2002, 12:03 PM   #1
jcmiley
Registered User
 
Join Date: Mar 2002
Location: Denver, CO
Posts: 6
89 4.0 XJ so weak I can't use 5th gear

Forgive my lack of knowledge guys, but this seems wrong. I have a 89 XJ that has absolutely no power at all. 4.0 and manual transmission. It feels as if it is not getting in advance in the ignition timing, but I am not sure. I had a 96 4.0 and that thing was awesome. My 89 has to stay in 4th gear at highway speeds with the accelerator on the floor just to maintain 60-65 mph.

Any takers?

__________________
Anemic 89 XJ
jcmiley is offline   Reply With Quote Quick reply to this message
Unread 03-21-2002, 01:50 PM   #2
CB89XJ
Registered User
 
Join Date: Dec 2001
Location: Kutztown, PA
Posts: 608
Make sure the cat converter isn't clogged. This would really reduce the power.
__________________
Colin Beatty
'87 YJ, built 351W, T-18, NP-205, SOA, SRS, 35x12.50 ProComp MT's, cage, winch, Tomken bumper/carrier, d44/9"

www.bmja.org
CB89XJ is offline   Reply With Quote Quick reply to this message
Unread 03-21-2002, 06:59 PM   #3
jcmiley
Registered User
 
Join Date: Mar 2002
Location: Denver, CO
Posts: 6
Thanks for the reply, but it has a brand new cat on it. The thing acts like it is not getting in advance in the timing.????

James
__________________
Anemic 89 XJ
jcmiley is offline   Reply With Quote Quick reply to this message
Unread 03-21-2002, 08:00 PM   #4
blue93xj
Registered User
 
Join Date: Mar 2002
Location: Georgia
Posts: 5
I have had two aftermarket cats on another vehicle die in a very short time after install. If it was not a factory part I might be suspicious.
If the timing is not advancing it should show symptoms in all gears not just 5th.
good luck
blue93xj is offline   Reply With Quote Quick reply to this message
Unread 03-22-2002, 12:40 AM   #5
jcmiley
Registered User
 
Join Date: Mar 2002
Location: Denver, CO
Posts: 6
bump
__________________
Anemic 89 XJ
jcmiley is offline   Reply With Quote Quick reply to this message
Unread 03-22-2002, 08:10 PM   #6
Brian Peake
Registered User
 
Join Date: Mar 2002
Location: Vancouver Canada
Posts: 24
Parking Break On Buddy?
Brian Peake is offline   Reply With Quote Quick reply to this message
Unread 03-26-2002, 11:12 PM   #7
jcmiley
Registered User
 
Join Date: Mar 2002
Location: Denver, CO
Posts: 6
How does Jeep advance the timing on the 4.0? Is it vacumn or all done through the ECU. I checked the cat (gutted it!) and still nothng. Is anybody else experiencing similar symptoms?

TIA
James
__________________
Anemic 89 XJ
jcmiley is offline   Reply With Quote Quick reply to this message
Unread 03-30-2002, 01:34 PM   #8
jcmiley
Registered User
 
Join Date: Mar 2002
Location: Denver, CO
Posts: 6
I think I may have found at least part of the problem. The tires on it are 235/75/r15's. My neighbors jeep has 215/75/r15. Also found out the other night that my speedo is @ 10 mph slower than actual speed. ie.. says 65 while doing 75. By screwing up the final drive ratio so bad, I figure that is why I'm not in my power band. It would be like you guys putting your xj into 5th while only going 40 mph...

any takers?
__________________
Anemic 89 XJ
jcmiley is offline   Reply With Quote Quick reply to this message
Unread 03-30-2002, 01:48 PM   #9
Travis
Registered User
 
Join Date: Feb 2002
Location: Ky
Posts: 43
Nah. I have 235's also and mine has power well beyond 65 or 75. I just can't seem to get that sputter out of it. I think it's my vacuum hoses but I can't find a diagram anywhere. 89' cherokee 4.0
Travis is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.