88' XJ Cranks, Won't Turn Over After Stopping - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 11-07-2008, 12:35 PM Thread Starter
Motorcharge
Bandeded
 
Motorcharge's Avatar
 
Join Date: Oct 2008
Posts: 13,696
88' XJ Cranks, Won't Turn Over After Stopping

I've got an 88' XJ Laredo.
Brand new ignition module and coil.
It runs and runs perfectly when it does, but when I stop I have to open the hood for 5-10 min before it will start back up. It'll crank, but it just won't start right up if I've been driving. I drove about 100 miles today before stopping with zero problems, stopped and went inside my aunts house for about 20 min and it wouldn't start. Wasn't over heated, all my fluid levels are fine, battery is fine.

above is a repost, but something I just thought of, this only started happening after I ran out of gas. It ran perfectly out to the inspection station about 50 miles from me and back. I ran out of gas like a block from the gas station. Pushed it there, filled up, started right back up. I got home and went to leave about 30 min later and its been happening ever since.

Also, I was sitting at a light the other night and it shut off and wouldnt turn back over for another 15 min or so. (apparently people dont understand hazard lights )

Motorcharge is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-07-2008, 02:43 PM Thread Starter
Motorcharge
Bandeded
 
Motorcharge's Avatar
 
Join Date: Oct 2008
Posts: 13,696
Motorcharge is offline  
post #3 of 6 Old 11-07-2008, 03:09 PM
JTruel
Registered User
2005 LJ Wrangler 
 
Join Date: Mar 2003
Location: Broken Arrow, OK
Posts: 413
Is it cranking and not starting? Or not cranking at all when you turn the key?

2000 XJ Classic
2005 LJ
JTruel is offline  
post #4 of 6 Old 11-07-2008, 03:15 PM Thread Starter
Motorcharge
Bandeded
 
Motorcharge's Avatar
 
Join Date: Oct 2008
Posts: 13,696
cranks and doesn't start
Motorcharge is offline  
post #5 of 6 Old 11-07-2008, 03:22 PM
JTruel
Registered User
2005 LJ Wrangler 
 
Join Date: Mar 2003
Location: Broken Arrow, OK
Posts: 413
Sounds like the CPS is on the fritz (Crank Position Sensor) do a search, look at the symptoms and fixes of other members. Verify that is what yours is doing.

included a link to a CPS failure thread also

http://www.jeepforum.com/forum/f11/all-points-cps-622005/

good luck! keep us posted

2000 XJ Classic
2005 LJ
JTruel is offline  
post #6 of 6 Old 11-07-2008, 03:40 PM Thread Starter
Motorcharge
Bandeded
 
Motorcharge's Avatar
 
Join Date: Oct 2008
Posts: 13,696
yep, thats gotta be it, reading came out low.
thanks
anyone got a rough price on what these run?
cant seem to find it on google.
Motorcharge is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
4.0 stalled on hard right turn, cranks but doesn't fire, no spark. Help fix it! johnsoninc86 XJ Cherokee Technical Forum 2 10-14-2009 05:13 PM
Has power, cranks, but won't turn over Flojo8000 XJ Cherokee Technical Forum 6 07-24-2009 11:27 AM
2001 Grand Cherokee 4.0 cranks will not turn over. GoldMine63 XJ Cherokee Technical Forum 5 04-24-2009 09:45 AM
87 Comanche cranks but wont turn over Ethox MJ Comanche Technical Forum 8 03-30-2009 10:06 PM
4.0 cranks for awhile before it will turn pfishe XJ Cherokee Technical Forum 8 10-25-2008 01:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome