88 Cherokee will not idle - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 88 Cherokee will not idle

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201FS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 05-13-2013, 07:34 PM   #1
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
88 Cherokee will not idle

As the title states, also VERY hard to start, have to pump gas to started and keep running. I cannot hold it, i have to pump it. While it is cold if i let rpms get low sounding it bogs out or if they get high it bogs out. But once warm it will run just not idle with out pumping it.

__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 06:07 AM   #2
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,775
What have you done so far?

Are your intake manifold bolts loose or missing?

Hose from throttle body to MAP messed up in any way?
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote
Unread 05-14-2013, 07:31 AM   #3
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
I have cleaned the throttle body and replaced vacuum lines, i have to go buy more line thought. That line looks good, after i cleaned it with parts cleaner it ran better but had a surging idle. Replacing a few lines fixed that. But it tries to correct idle but does die.
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 07:34 AM   #4
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
No bolts are missing but there us a hole above the map sensor line on the intake, it had nothing in it so i plugged it. I think i still have a leak and will keep looking for it, but have traced all lines with a vacuum diagram and not found it. Could i just eliminate that vacuum tree thing and run the lines directly to their connection?
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 02:05 PM   #5
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,775
Quote:
Originally Posted by 79chiefs View Post
No bolts are missing but there us a hole above the map sensor line on the intake, it had nothing in it so i plugged it. I think i still have a leak and will keep looking for it, but have traced all lines with a vacuum diagram and not found it. Could i just eliminate that vacuum tree thing and run the lines directly to their connection?
You mean hole above the vacuum line on the throttle body?
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote
Unread 05-14-2013, 02:18 PM   #6
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
Yes, it now has all new vacuum lines, it idles lower, but still stalls. It also has surging start up back. And it starts quicker now.
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 02:20 PM   #7
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
I am also have constant trouble with the starter clicking, then it will turn, then click click click, and turn. Lately it just clicks and once in a blue moon turn.
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 02:25 PM   #8
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,775
Quote:
Originally Posted by 79chiefs View Post
I am also have constant trouble with the starter clicking, then it will turn, then click click click, and turn. Lately it just clicks and once in a blue moon turn.
Bad battery, bad starter, bad cables, bad connections, bad grounds......
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote
Unread 05-14-2013, 02:36 PM   #9
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
Starter rebuilt, it works fine i replaced it same, so i got my money back. I did a ground refresh as i read that might help. Battery is new. I cleaned all connections i could find as stated in the ground refresh thread i read. I will be getting new cables as these are 25 years old.
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 03:00 PM   #10
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,775
Good plan.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote
Unread 05-14-2013, 03:08 PM   #11
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
Now, about that hole i plugged is it supposed to be plugged? I read a thread on the IAC, pulled it and i could hardly get it out. It was frozen in with carbon build up. But in the diagram that explained how it worked, it showed an air passage, and that hole at the end of it.
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 03:09 PM   #12
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
On my throttle body there is two holes not 4, one has the vacuum line for the MAP sensor in it the other i plugged.
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 03:10 PM   #13
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,775
I'm confused. What hole did you plug?
And with what?
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote
Unread 05-14-2013, 04:18 PM   #14
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
Plastic plug from an old refrigeration unit.
It in the pic but without plug.
Replaced battery cables, put two new negatives for extra ground, and still starter clicking. Could it not be getting a charge to turn? As in a relay engaging the solenoid for the gear to move to the flywheel, but not for the motor to turn, if that makes sense.
dscf0390_zps3264809b.jpg  
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote
Unread 05-14-2013, 04:21 PM   #15
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 936
http://www.jeepforum.com/forum/f11/8...m-leak-153902/
This tread explained it, i guess there is nothing in that hole.
__________________
79FSJ Cherokee Chief 350SBC_2x88 XJ Laredo I6-A 4wd_92XJ Laredo I6-A 4wd-SOLD
99WJ Laredo I6-A 2wd
79chiefs is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.