87 cherokee 4.0 idle problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 87 cherokee 4.0 idle problem

Jeep Grand Cherokee Mirror - Side ViewJeep Grand Cherokee Headlight AssembliesThe Retrofit Source / JW Speaker LED Headlight GROUP BUY!

Reply
Unread 07-19-2012, 06:37 PM   #1
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia, iowa
Posts: 11
87 cherokee 4.0 idle problem

I am getting an 87 wagoneer limited the Cherokee style and it has a 3.5 re lift and 31s with the 4.0 he says that when he starts it up that it idles rough and dies in park and gear and that sometimes it will idle fine it park and then die when put in gear .just wondering if anyone has any ideas what it could be o and he also said when he got it the egr valve was disconnected

xj34 is offline   Reply With Quote
Unread 07-21-2012, 05:47 PM   #2
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia, iowa
Posts: 11
Ok got the Jeep today it runs rough when you start it sometimes it backfires and it will spit gas out of throttlebody and when it starts it idles rough and runs very rich really need some help guys
xj34 is offline   Reply With Quote
Unread 07-21-2012, 08:34 PM   #3
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,921
Check the pipe/hose from the throttle body to the MAP sensor mounted on the firewall. Can't be melted, have any leaks or cracks.
cruiser54 is offline   Reply With Quote
Unread 07-22-2012, 07:52 AM   #4
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia, iowa
Posts: 11
Alright will check it I think its fine tho could it be the egr valve at all someone mentioned it to me
xj34 is offline   Reply With Quote
Unread 07-22-2012, 07:54 AM   #5
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia, iowa
Posts: 11
O and also when I hit the gas like pump it or hold to the floor it doesn't change much like it wont Rev up sometimes it dies
xj34 is offline   Reply With Quote
Unread 07-22-2012, 08:51 AM   #6
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,921
Quote:
Originally Posted by xj34 View Post
Alright will check it I think its fine tho could it be the egr valve at all someone mentioned it to me
Use some throttle body cleaner and spray along the MAP hose especially near the throttle body to check for vacuum leaks.
cruiser54 is offline   Reply With Quote
Unread 07-22-2012, 08:57 AM   #7
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia, iowa
Posts: 11
Alright and if I do it will it die Cuz I know when its idling rough and I unplug it it dies
xj34 is offline   Reply With Quote
Unread 07-22-2012, 11:54 AM   #8
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,921
Quote:
Originally Posted by xj34 View Post
Alright and if I do it will it die Cuz I know when its idling rough and I unplug it it dies
The idle will change when the spray hits the leak. Go for it.
cruiser54 is offline   Reply With Quote
Unread 07-22-2012, 01:53 PM   #9
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia, iowa
Posts: 11
Alright I will give it a try tomorrow and see if it makes a difference
xj34 is offline   Reply With Quote
Unread 07-27-2012, 06:22 PM   #10
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia, iowa
Posts: 11
So did some work on it today I have sprayed around all the vacuum lines and no leaks that I can tell and I tried unplugging the iac and there was no change at all when I hit the gas it wont Rev up at all it sometimes backfires if I unplug the map while running it dies what could it be
xj34 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.