87 cherokee 4.0 idle problem - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 07-19-2012, 06:37 PM Thread Starter
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia
Posts: 11
87 cherokee 4.0 idle problem

I am getting an 87 wagoneer limited the Cherokee style and it has a 3.5 re lift and 31s with the 4.0 he says that when he starts it up that it idles rough and dies in park and gear and that sometimes it will idle fine it park and then die when put in gear .just wondering if anyone has any ideas what it could be o and he also said when he got it the egr valve was disconnected

xj34 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 07-21-2012, 05:47 PM Thread Starter
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia
Posts: 11
Ok got the Jeep today it runs rough when you start it sometimes it backfires and it will spit gas out of throttlebody and when it starts it idles rough and runs very rich really need some help guys
xj34 is offline  
post #3 of 10 Old 07-21-2012, 08:34 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,106
Check the pipe/hose from the throttle body to the MAP sensor mounted on the firewall. Can't be melted, have any leaks or cracks.
cruiser54 is offline  
post #4 of 10 Old 07-22-2012, 07:52 AM Thread Starter
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia
Posts: 11
Alright will check it I think its fine tho could it be the egr valve at all someone mentioned it to me
xj34 is offline  
post #5 of 10 Old 07-22-2012, 07:54 AM Thread Starter
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia
Posts: 11
O and also when I hit the gas like pump it or hold to the floor it doesn't change much like it wont Rev up sometimes it dies
xj34 is offline  
post #6 of 10 Old 07-22-2012, 08:51 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,106
Quote:
Originally Posted by xj34 View Post
Alright will check it I think its fine tho could it be the egr valve at all someone mentioned it to me
Use some throttle body cleaner and spray along the MAP hose especially near the throttle body to check for vacuum leaks.
cruiser54 is offline  
post #7 of 10 Old 07-22-2012, 08:57 AM Thread Starter
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia
Posts: 11
Alright and if I do it will it die Cuz I know when its idling rough and I unplug it it dies
xj34 is offline  
post #8 of 10 Old 07-22-2012, 11:54 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,106
Quote:
Originally Posted by xj34 View Post
Alright and if I do it will it die Cuz I know when its idling rough and I unplug it it dies
The idle will change when the spray hits the leak. Go for it.
cruiser54 is offline  
post #9 of 10 Old 07-22-2012, 01:53 PM Thread Starter
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia
Posts: 11
Alright I will give it a try tomorrow and see if it makes a difference
xj34 is offline  
post #10 of 10 Old 07-27-2012, 06:22 PM Thread Starter
xj34
Registered User
 
Join Date: Jul 2012
Location: new virginia
Posts: 11
So did some work on it today I have sprayed around all the vacuum lines and no leaks that I can tell and I tried unplugging the iac and there was no change at all when I hit the gas it wont Rev up at all it sometimes backfires if I unplug the map while running it dies what could it be
xj34 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
89 cherokee bouncing idle problem jgi187b XJ Cherokee Technical Forum 28 06-19-2015 08:36 AM
1996 Cherokee idle surge/die problem... Julian1221 XJ Cherokee Technical Forum 8 10-08-2009 01:46 PM
cherokee idle problem hockeykid3824 XJ Cherokee Technical Forum 0 05-22-2008 03:10 PM
Rogh Idle in a 90 Cherokee Lmt. Vacuum Problem? kamspy XJ Cherokee Technical Forum 4 04-28-2008 08:29 PM
90' Cherokee Idle Problem ddoffroad XJ Cherokee Technical Forum 7 08-18-2002 12:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome