86 Cherokee OVERCHARGING - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 86 Cherokee OVERCHARGING

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineHalloween Savings to die for!We have Engo 10k Synthetic IN STOCK!!! Hurry while supplie

Reply
Unread 06-19-2013, 04:02 PM   #1
BIGEARS270
Registered User
1984 CJ7 
 
Join Date: Oct 2011
Location: Ft. Collins, Colorado
Posts: 5
86 Cherokee OVERCHARGING

I am having a overcharging problem with a 86 Cherokee with a 2.5L. It ran good after sitting a couple months. Now that it is overcharging the engine(16v-17v) and will spit spuder then die. I have replaced the battery and the alternator with no change. If i pull the field wire off it runs perfect. I have read some suggestions to check the resistance on the fielding wire or replacing the ECM, but that was for late 90's xjs with 4.0L. Will it be the same for my vehicle or is there something i am overlooking?

Any help would be greatly appreciated!
Thank.

BIGEARS270 is offline   Reply With Quote Quick reply to this message
Unread 06-19-2013, 11:22 PM   #2
NOTNSUV
Registered User
 
Join Date: Jan 2012
Location: Spring Creek, Nevada
Posts: 46
Had overcharge also. Replaced major wires from battery and hot and ground wires to starter,etc. no more issues.
NOTNSUV is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 02:07 PM   #3
BIGEARS270
Registered User
1984 CJ7 
 
Join Date: Oct 2011
Location: Ft. Collins, Colorado
Posts: 5
Hey Thanks! I am trying to gather as much in info and parts possible. The jeep belongs to my grandfather who lives an hour away from any parts stores in the mountains. Hopefully with what i gather it'll do the trick!
BIGEARS270 is offline   Reply With Quote Quick reply to this message
Unread 06-28-2013, 02:58 PM   #4
BIGEARS270
Registered User
1984 CJ7 
 
Join Date: Oct 2011
Location: Ft. Collins, Colorado
Posts: 5
We went through everything again and it ended up being the ecm. Runs great again!
Thanks!
BIGEARS270 is offline   Reply With Quote Quick reply to this message
Reply

Tags
2.5l , xj

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.