4.0 will crank but will not start.... - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 07-26-2009, 11:43 AM Thread Starter
MarkwithaK
Registered User
1998 XJ Cherokee 
 
Join Date: Jul 2009
Location: Indiana
Posts: 74
4.0 will crank but will not start....

I recently bought a '98 Cherokee Classic from a good friend. On Christmas Eve he went to move the Jeep and hit a small bump, the vehicle just quit at that point. It would crank but would not start. Eventually he sold the problem to me for a measly $400.00.

I changed out the CPS and still no start. I then replaced the cap and wires with no luck. I found no spark to the cap and eventually found no voltage to the coil itself. I have a strong electrical background and figure to start at the source....I assume that would be the ICM?



While it is unfortunate that I had to find this forum under this circumstance I am glad I have. Thank you in advance for any help.

MarkwithaK is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 07-26-2009, 11:50 AM
xjfever
Web Wheeler
 
xjfever's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2008
Location: north Ga.
Posts: 14,216
I would test all fuses and relays to begin with, then test the cam position sensor under the distributor cap.

  1. '95 XJ country edition, 4" coils/3/4" spacers, HD leafs with extra main added in, Ironman adjustable control arms, rough country shackles, aussie locker, JK rubicon shocks, 35" mudder's, soft 8's, cobra cb
  2. Sold'99 WJ limited, 4.7L, 3" IRO lift. Bilstein shocks, JK rubicon wheels, 255/70/17's, carolina driveshaft, IRO adjustable control arms, IRO adjustable A-arm
  3. Sold '00 TJ, 4" lift, rusty's adjustable control arms, skyjacker shocks, rock krawler adj. trac-bar,rugged ridge SYE and RE driveshaft, soft 8's, 35" mud king xt's,XJ HP D30 w/aussie locker, 4:88 yukon gears, hella 500's, rock crusher diff covers
4. 04 Dodge ram 1500 quadcab, yes, it has a hemi.
5. '08 BMW X3, Mods in progress.
xjfever is offline  
post #3 of 8 Old 07-26-2009, 12:09 PM Thread Starter
MarkwithaK
Registered User
1998 XJ Cherokee 
 
Join Date: Jul 2009
Location: Indiana
Posts: 74
Thanks for the info. All fuses and relays have been tested. Forgive my ignorance but even if the cam sensor has failed wouldn't I still get spark from the coil itself?
MarkwithaK is offline  
 
post #4 of 8 Old 07-26-2009, 12:21 PM
xjfever
Web Wheeler
 
xjfever's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2008
Location: north Ga.
Posts: 14,216
Yeah, I was distracted when reading the post. You will most likely have to start at the coil and backtrack to find where the voltage is lost.

  1. '95 XJ country edition, 4" coils/3/4" spacers, HD leafs with extra main added in, Ironman adjustable control arms, rough country shackles, aussie locker, JK rubicon shocks, 35" mudder's, soft 8's, cobra cb
  2. Sold'99 WJ limited, 4.7L, 3" IRO lift. Bilstein shocks, JK rubicon wheels, 255/70/17's, carolina driveshaft, IRO adjustable control arms, IRO adjustable A-arm
  3. Sold '00 TJ, 4" lift, rusty's adjustable control arms, skyjacker shocks, rock krawler adj. trac-bar,rugged ridge SYE and RE driveshaft, soft 8's, 35" mud king xt's,XJ HP D30 w/aussie locker, 4:88 yukon gears, hella 500's, rock crusher diff covers
4. 04 Dodge ram 1500 quadcab, yes, it has a hemi.
5. '08 BMW X3, Mods in progress.
xjfever is offline  
post #5 of 8 Old 07-26-2009, 05:05 PM Thread Starter
MarkwithaK
Registered User
1998 XJ Cherokee 
 
Join Date: Jul 2009
Location: Indiana
Posts: 74
That is along the line of what I imagined. I read through the wiring schematics in my Haynes manual but it seems to offer up 2 similar yet equally incomplete versions for this year/engine combo. I suspect it to be one of two things (broken wire or failed ECU) but I could be so very wrong.
MarkwithaK is offline  
post #6 of 8 Old 07-26-2009, 06:23 PM
coppertop71
Senior Member
 
coppertop71's Avatar
1990 XJ Cherokee 
 
Join Date: Jun 2004
Location: Vancouver, WA
Posts: 953
Check the harness up to the CPS if its loose it can melt along the exhaust down pipe.

Not sure if your 98 is the same but my coil sits on top of the ignition module, it snaps into contact points underneath the coil maybe there dirty and need cleaning or the module could be bad it self.

Mods
2006 Jeep Wrangler X, 4.0 4:11 gears

'90 Cherokee XJ,W/'91 4.0L reman/ 3.5" RE lift, W/31" M/S tires, 4:11 Gears W/Speedo gear change/ Aluminum Coolant Tank
A/C Conversion/Home Built Roof Rack/K&N Box Filter
Derale 15" Rigid Radiator Fan PT# DER-17415, through Summit W/2"X5/8X5/8"" spacer


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
coppertop71 is offline  
post #7 of 8 Old 07-26-2009, 07:33 PM Thread Starter
MarkwithaK
Registered User
1998 XJ Cherokee 
 
Join Date: Jul 2009
Location: Indiana
Posts: 74
The CPS harness shows no signs of damage. My coil actually sits on the passenger side of the engine block. It is bolted to a metal bracket. I did notice that the 2 wires that lead to the plug seemed to be rather tight and may have been creased. Not sure if I'm getting continuity. I was trying to check the wire back to the ECM but the wiring diagram I have is a bit misleading perhaps.
MarkwithaK is offline  
post #8 of 8 Old 07-27-2009, 09:48 AM
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota
Posts: 8,847
Garage
There is a connector for the crank sensor under the hood back near the firewall/#6 injector. Unplug it and clean it with electrical contact cleaner. If the contacts in that connector are dirty, it can inhibit the crank sensor signal from making it to the computer.

99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
91 XJ No Crank, No Start 91XJinNC XJ Cherokee Technical Forum 11 05-30-2009 10:21 PM
crank but no start Willy36 XJ Cherokee Technical Forum 1 04-15-2008 09:50 PM
crank crank crank no start lostxj XJ Cherokee Technical Forum 8 04-05-2008 11:36 AM
crank crank no start xj 911tj XJ Cherokee Technical Forum 0 08-04-2007 07:51 PM
crank crank crank then start GDSQDCR MJ Comanche Technical Forum 2 08-29-2005 12:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome