4.0 Oil Pump Dilemma - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 10-17-2013, 06:52 PM Thread Starter
Registered User
1995 YJ Wrangler 
Join Date: Apr 2011
Location: West Babylon
Posts: 40
4.0 Oil Pump Dilemma

Hey Guys,

A faulty oil pump ruined my brand new rebuild. Notice in the pictures how the new oil pump sits cocked off the block where as the original oil pump sits perfectly flush on the block.

Also now when I was reassembling the engine, a 30 minute timing chain has .40" of play in it!!!!

What to do????

Any advise would be greatly appreciated.

Attached Thumbnails
MOPAR.jpg   Enginetech.jpg  
PilotPat24 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome