2High engages fine but 4High/low doesn't? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 2High engages fine but 4High/low doesn't?

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 08-15-2013, 10:16 PM   #1
RenanMilk
Registered User
2001 XJ Cherokee 
 
Join Date: Jun 2013
Location: Deerfield Beach, FL
Posts: 12
2High engages fine but 4High/low doesn't?

Drove over a pile of dirt+rocks one day while in 4high and I guess my front differential struck it.

Only in 4High/Low does this happen:
-My car won't idle forward anymore.
-When I gas it, a grinding noise starts that increases in pitch and volume with speed.
-Makes my wheels pull to the right.

Not very experienced with automotives yet but I know what's what.

RenanMilk is offline   Reply With Quote Quick reply to this message
Unread 08-16-2013, 11:36 AM   #2
CJ7-Tim
Real Jeeps have dents.
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis, Minnesota
Posts: 21,823
Adjust the 4x4 linkage.


.
__________________
.

Between 2009 when Obama took office, and 2013, median annual household incomes have fallen by more than $2,100.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ......

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline   Reply With Quote Quick reply to this message
Unread 08-16-2013, 06:04 PM   #3
RenanMilk
Registered User
2001 XJ Cherokee 
 
Join Date: Jun 2013
Location: Deerfield Beach, FL
Posts: 12
Never seen that before. I'll give it a shot.
RenanMilk is offline   Reply With Quote Quick reply to this message
Unread 08-16-2013, 08:35 PM   #4
RenanMilk
Registered User
2001 XJ Cherokee 
 
Join Date: Jun 2013
Location: Deerfield Beach, FL
Posts: 12
So I stuck my head under the car and took a look. I found the shift linkage but I didn't mess with it yet, I don't really know what to adjust it to. I also noticed something else.

There is a line that runs into the rear side, top-left corner of my front differential. That line is bent. Would that have to do with any of my issues? I'll upload pics tomorrow because it's night here now and I can't get any good pics.
RenanMilk is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.