1999 4.0l starts but won't continue to run without gas peddle assist. - JeepForum.com

 
LinkBack Thread Tools
post #1 of 13 Old 10-22-2008, 07:55 AM Thread Starter
gyurko
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2008
Location: Sugarloaf, PA.
Posts: 3
1999 4.0l starts but won't continue to run without gas peddle assist.

My 1999 4.0L with 83K. has started to episodically fail to start without gas being depressed and will not idle without gas feed help. Without gas feed being depressed it will stall. After driving a few minuets it will run normally and start normally until it occurs again. No fault codes come up. Appreciate any suggestions or similar experiences and solutions. Thanks.

gyurko is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 10-22-2008, 08:35 AM
96cherokeeclass
Registered User
1996 XJ Cherokee 
 
Join Date: Aug 2005
Location: College Station, Tx
Posts: 712
Quote:
Originally Posted by gyurko View Post
My 1999 4.0L with 83K. has started to episodically fail to start without gas being depressed and will not idle without gas feed help. Without gas feed being depressed it will stall. After driving a few minuets it will run normally and start normally until it occurs again. No fault codes come up. Appreciate any suggestions or similar experiences and solutions. Thanks.
same thing happened to me... believe it or not a new battery fixed it

- 07 WK - CRD
96cherokeeclass is offline  
post #3 of 13 Old 10-22-2008, 09:03 AM
CJ7-Tim
Real Jeeps have dents
 
CJ7-Tim's Avatar
2000 XJ Cherokee 
 
Join Date: Apr 2002
Location: out in the garage - Minneapolis
Posts: 24,680
Those are the common symptoms of a bad battery. Take it to a repair shop or parts store and have it load tested.

.

A recent Gallup public opinion poll shows the NRA, at 58% approval, has a higher approval rating than either Hillary Clinton or Barack Obama.

Progressive Liberalism: Bringing you new Healthcare ideas so wonderful, they have to include mandatory participation ...

Originally Posted by Ronald W. Reagan: Government is not the solution to our problems; Government is the problem.
CJ7-Tim is offline  
post #4 of 13 Old 10-22-2008, 09:05 AM
bwoo90
Registered User
2015 WK 
 
Join Date: Sep 2008
Location: Florida
Posts: 139
Could be bad gas, could be a TPS, could be alternator going, might try cleaning the IAC.

2015 Jeep Grand Cherokee Overland
2001 Jeep Grand Cherokee
1992 Jeep Cherokee
1988 Jeep Cherokee
bwoo90 is offline  
post #5 of 13 Old 10-22-2008, 09:07 AM
scupking
Registered User
1999 XJ Cherokee 
 
Join Date: Dec 2007
Location: Enfield, CT
Posts: 268
It's a bad IAC trust me. This happened to me on my mustang. It would start sometime without an issue, other times I had to keep my foot on the gas to keep it from dying. After driving it for a few minutes it would idle fine. I replaced my IAC and all is good.
scupking is offline  
post #6 of 13 Old 10-22-2008, 09:23 AM
96cherokeeclass
Registered User
1996 XJ Cherokee 
 
Join Date: Aug 2005
Location: College Station, Tx
Posts: 712
Start with the simplest solution and work your way up

- 07 WK - CRD
96cherokeeclass is offline  
post #7 of 13 Old 10-22-2008, 09:28 AM
Cherokee2000
Registered User
2000 XJ Cherokee 
 
Join Date: Jan 2008
Location: Montreal
Posts: 244
Happened to me twice. Both times it was because my battery was near dead. If your battery is still good, then X3 on your IAC.
Cherokee2000 is offline  
post #8 of 13 Old 10-22-2008, 10:18 AM
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota
Posts: 8,749
Garage
Testing is best way to figure this one out. Start with battery, then TPS IMHO.

99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline  
post #9 of 13 Old 10-22-2008, 10:23 AM
kadetklapp
Registered User
1997 XJ Cherokee 
 
Join Date: May 2008
Location: Indiana
Posts: 1,357
Unhook the battery and then hook it back up and see what happens. If not then I would guess TPS.

**1997 Jeep Cherokee SE**
Former Police Car assigned to 54-26, RIP.
kadetklapp is offline  
post #10 of 13 Old 10-22-2008, 10:40 AM
jebmccall
Registered User
1997 XJ Cherokee 
 
Join Date: Jun 2008
Location: woodstock
Posts: 970
thats happens to me when ever my battery dies i have to help it idle for a few minutes, and then all is good
jebmccall is offline  
post #11 of 13 Old 10-30-2008, 08:05 AM Thread Starter
gyurko
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2008
Location: Sugarloaf, PA.
Posts: 3
Thanks for all the advice everyone. I discovered that the battery termnals were dirty and cleaned tham up and have driven the vehicle for the past week without a glitch. Never would ahve suspected that the no idle situation could be caused by low battery output.
gyurko is offline  
post #12 of 13 Old 10-30-2008, 09:55 AM
bwoo90
Registered User
2015 WK 
 
Join Date: Sep 2008
Location: Florida
Posts: 139
Thank-you for coming back with a follow-up. All too often we never hear back.
bwoo90 is offline  
post #13 of 13 Old 10-30-2008, 02:54 PM
collkid
Registered User
2000 XJ Cherokee 
 
Join Date: Apr 2007
Location: Highlands Ranch, Colorado
Posts: 1,845
Dang that is kind of weird, good thing to know.

2000 Jeep Cherokee. 4.5', Long arms, Bumpers front and rear, Winch.
1992 Toyota Paseo DD 35+ MPG
Colorado Member #89
collkid is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2.5 wont idle unless pump gas peddle GooberTard XJ Cherokee Technical Forum 7 09-17-2009 11:08 AM
4.0 starts but low rpm's and now starts and stalls Radium08 XJ Cherokee Technical Forum 1 07-22-2009 12:53 PM
Jeep troubles continue... shifting Thmastr XJ Cherokee Technical Forum 3 12-26-2007 11:49 PM
Hydro Assist? XJ Jeremy XJ Cherokee Technical Forum 1 09-05-2007 08:15 PM
Brake peddle tapping sjns XJ Cherokee Technical Forum 10 02-09-2004 08:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome