1998 XJ - Odometer reads 'NO BUS' - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 03-30-2011, 12:10 PM Thread Starter
Timstock
Registered User
1999 XJ Cherokee 
 
Join Date: Jun 2009
Location: Chelan wa
Posts: 76
1998 XJ - Odometer reads 'NO BUS'

I have a 98 cherokee sport and all of my guages work EXCEPT the Odomiter, it does not say "no bus" and there are no running conditions.

any ideas of what is wrong? what ground controls the guage?. i could use a guage schematic if anybody has one. or any other ideas or pics would help thank you!

Timstock is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-30-2011, 06:48 PM
BeachinXJ
Resident McGeek
 
BeachinXJ's Avatar
2000 XJ Cherokee 
 
Join Date: Jun 2003
Location: The Beach®
Posts: 5,836
Usually, if nothing on the jeep is not working / running poorly other than the cluster, it's the connection on the back of it. You need to take the dash apart, and remove the connection on the back of the cluster. Clean it, apply a little dielectric grease, and reassemble. Should be good to go.

2000 Jeep XJ - Chopped / Locked
1997 Jeep XJ - Daily Driver
2003 Dodge Ram 2500 CTD - 6-speed, 4" MBRP Turbo Back Exhaust
Join the XJ Owners Club | Download the iMarn® iPhone App!
SIRA 4x4 Offroad Association
Rule #1 - No talking about the weather!
Homepage | Jeepspace Group|Twitter!|Facebook
BeachinXJ is offline  
post #3 of 4 Old 03-30-2011, 06:52 PM
XJcruiser
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2009
Location: San Antonio
Posts: 1,268
Mine did this 2 years ago. I did just like Beachin said and it hasnt done it since.

Friends dont let friends do DUBS.
XJcruiser is offline  
post #4 of 4 Old 03-31-2011, 05:21 AM
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota
Posts: 8,744
Yup. Follow guidance from above and you should have a good chance of resolving this.

99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is offline  
Reply

Tags
cluster , guages , No bus , odometer , odometer problem , xj

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Odometer reads NO BUS, plus rocker panel ? RicheB413 XJ Cherokee Technical Forum 5 09-24-2010 06:00 PM
86 XJ tach reads wrong 2point8 XJ Cherokee Technical Forum 1 10-17-2008 04:41 PM
99 XJ temp gauge reads 0 Xjcrusader XJ Cherokee Technical Forum 3 10-30-2007 06:43 PM
99 xj code reads: no bus BAJAMAN XJ Cherokee Technical Forum 6 05-03-2006 01:54 AM
Since nobody reads the other forum.... Mr98Pontiac XJ Cherokee Technical Forum 2 11-12-2002 12:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome