1996 cherokee whine - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 1996 cherokee whine

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 12-19-2012, 08:35 PM   #1
cherokeeshrop91
Registered User
2009 KK Liberty 
 
Join Date: Feb 2011
Location: ormond beach, florida
Posts: 47
1996 cherokee whine

alright well i have a 96 cherokee classic 4wd 4door. lifted 4.5 on 33/12.50/15 mud tires. ive put considerable work into from front to prevent wobble problems and regular maintenence has been well taken care of. when i bout it about 2 yrs ago i had to replace tranny and other things... its always made a grinding noise when i accelerate or let off the gas pedal. i was told the gears may need to be replaced but when lookd at was told they were fine. problem is now when cruising about 45-50mph and over at random intervols i get a whine. it starts out really low and grows untill its faily loud. im not sure what could be causing the problem. but my guess would be that its comming from the rear end. the noise seems to come threw the stereo almost but when its off it still happens. any help with this would be greatly appreciated. also if youd like to talk more about it feel free to pm me. thanks for the help.

cherokeeshrop91 is offline   Reply With Quote
Unread 12-19-2012, 09:06 PM   #2
sluff28
Registered User
2001 XJ Cherokee 
 
Join Date: Sep 2011
Location: Beech Bluff, Tn
Posts: 150
do you mean it sounds like its coming through the rear speakers
sluff28 is offline   Reply With Quote
Unread 12-21-2012, 06:28 AM   #3
cherokeeshrop91
Registered User
2009 KK Liberty 
 
Join Date: Feb 2011
Location: ormond beach, florida
Posts: 47
Im not entirely sure but yet it is almost as if whatever it is is amplifyd threw the speakers.
__________________
-R.I.P 96 XJ 4x4 w/ 4.5 R.C lift,
& 33/12.50/15 M/T's mostly built.
-Current 2009 Jeep Liberty KK 4x4,
stock but not for long.
cherokeeshrop91 is offline   Reply With Quote
Unread 12-21-2012, 02:39 PM   #4
buildin1XJ
Registered User
1999 XJ Cherokee 
 
Join Date: Oct 2011
Location: Knoxville, Tn.
Posts: 1,518
Check out your u joints in the rear drive shaft,pull the rear shaft and go for a very short drive and seee if it is still there.It's not the radio.
buildin1XJ is offline   Reply With Quote
Unread 12-30-2012, 02:48 PM   #5
cherokeeshrop91
Registered User
2009 KK Liberty 
 
Join Date: Feb 2011
Location: ormond beach, florida
Posts: 47
thanks I'll give that a try.it seems like it only happens when I drive for long periods of time
__________________
-R.I.P 96 XJ 4x4 w/ 4.5 R.C lift,
& 33/12.50/15 M/T's mostly built.
-Current 2009 Jeep Liberty KK 4x4,
stock but not for long.
cherokeeshrop91 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.