1996 cherokee 4wd whine? - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 12-14-2012, 12:07 AM Thread Starter
Registered User
2009 KK Liberty 
Join Date: Feb 2011
Location: ormond beach
Posts: 87
1996 cherokee 4wd whine?

alright well i have a 96 cherokee classic 4wd 4door. lifted 4.5 on 33/12.50/15 mud tires. ive put considerable work into from front to prevent wobble problems and regular maintenence has been well taken care of. when i bout it about 2 yrs ago i had to replace tranny and other things... its always made a grinding noise when i accelerate or let off the gas pedal. i was told the gears may need to be replaced but when lookd at was told they were fine. problem is now when cruising about 45-50mph and over at random intervols i get a whine. it starts out really low and grows untill its faily loud. im not sure what could be causing the problem. but my guess would be that its comming from the rear end. the noise seems to come threw the stereo almost but when its off it still happens. any help with this would be greatly appreciated. also if youd like to talk more about it feel free to pm me. thanks for the help.

cherokeeshrop91 is offline  

cherokee , noises , problems after lift , rear axle , whine

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome