post #1 of Old 02-10-2009, 08:33 AM Thread Starter
4hrs2Moab
Registered User
1990 XJ Cherokee 
 
Join Date: Jan 2009
Location: Ut
Posts: 87
1990 XJ 4.0 running rich

I just bought this Jeep last night. The PO put new battery cables and battery in it, but they didn't put the cables in correctly. It barely ran when i picked it up but i drove it to a parking lot and discovered the ground strap from the valve cover to chassis was broken so I connected that and it idled smooth, lights were bright again, gauges worked, but it didn't solve the problem of running rich. I will rev it up and the damn thing smokes like a diesel but while driving, I cant see visible smoke out the window. My friend that was following me said it still stinks while on the freeway. What might be wrong? Oxygen sensor? CTS? TPS? BBQ?

4hrs2Moab is offline  
post #2 of Old 02-10-2009, 08:38 AM
balloo93
Little Red Menace
 
balloo93's Avatar
1993 XJ Cherokee 
 
Join Date: Aug 2002
Location: Austin, TX
Posts: 20,821
More than likely the O2 is out or on it's way out. How many miles on it?

93 Sport
Beer is proof that God loves us and wants us to be happy............Ben Franklin


Specs in Profile.

http://www.cardomain.com/ride/325707/1
http://www.cardomain.com/ride/2406854/1
balloo93 is offline  
post #3 of Old 02-10-2009, 08:54 AM Thread Starter
4hrs2Moab
Registered User
1990 XJ Cherokee 
 
Join Date: Jan 2009
Location: Ut
Posts: 87
4hrs2Moab is offline  
post #4 of Old 02-10-2009, 08:57 AM
LobstahJeep
Registered User
2001 XJ Cherokee 
 
Join Date: Jan 2009
Location: Portland
Posts: 625
Pic for no click:

1981 CJ7
2001 XJ
ΜΟΛΩΝ ΛΑΒΕ
LobstahJeep is offline  
post #5 of Old 02-10-2009, 09:01 AM
tjwalker
It's the crank sensor!
 
tjwalker's Avatar
1999 XJ Cherokee 
 
Join Date: Nov 2007
Location: Central Minnesota
Posts: 8,734
Might not hurt to run a compression test on it so that you know where you're at (somewhat) mechanically. Only takes some of your time. Don't want to be chasing your tail here....

Did the previous owner have anything to say about this or oil consumption?

99 Cherokee, 4.0 AW4, NP242
Past Jeeps: 49 Willys, 81 Scrambler, 88 Comanche
Without "data", all you have is an opinion!
tjwalker is online now  
post #6 of Old 02-10-2009, 09:12 AM
LobstahJeep
Registered User
2001 XJ Cherokee 
 
Join Date: Jan 2009
Location: Portland
Posts: 625
Quote:
Originally Posted by tjwalker View Post
Did the previous owner have anything to say about this or oil consumption?
Here is the original ad that Mat found the Jeep on:
http://www.ksl.com/index.php?sid=&ni...iew&ad=1091463

1981 CJ7
2001 XJ
ΜΟΛΩΝ ΛΑΒΕ
LobstahJeep is offline  
post #7 of Old 02-10-2009, 09:16 AM Thread Starter
4hrs2Moab
Registered User
1990 XJ Cherokee 
 
Join Date: Jan 2009
Location: Ut
Posts: 87
4hrs2Moab is offline  
post #8 of Old 02-10-2009, 09:45 AM
1990JEEPXJ
Registered User
 
1990JEEPXJ's Avatar
1990 XJ Cherokee 
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 7,141
it could be a loose vacuum line somewhere. maybe the map sensor as well.

Completely stock, and keeping it that way...

My POS
Quote:
Originally Posted by Joe Dillard View Post
Yea, and I thought it was one of the 11 Commandments:
11) Thou shalt love, cherish, and honor till death, thine square headlights above all other earthy things sayith the Lord.
1990JEEPXJ is offline  
post #9 of Old 02-10-2009, 09:59 AM Thread Starter
4hrs2Moab
Registered User
1990 XJ Cherokee 
 
Join Date: Jan 2009
Location: Ut
Posts: 87
where is the map sensor? is it mounted up on the firewall? that was missing but i took it off the other jeep thats at my house and it still smoked
4hrs2Moab is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Fix running rich! JeepinXJstyle XJ Cherokee Technical Forum 6 11-19-2009 11:28 PM
Running Rich Meltedmechanic XJ Cherokee Technical Forum 21 05-10-2008 10:01 AM
1990 XJ Rich idle.. JoeOffRoad XJ Cherokee Technical Forum 0 02-15-2008 10:36 PM
running rich freedomhunter XJ Cherokee Technical Forum 3 12-30-2007 09:36 PM
Running Rich 4.0 ?? NOS/86 XJ Cherokee Technical Forum 3 09-29-2004 01:47 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome