1990 Cherokee Laredo 4.0L won't start - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 09-26-2006, 10:02 PM Thread Starter
thjofe
Registered User
 
Join Date: Sep 2006
Location: Arizona
Posts: 2
1990 Cherokee Laredo 4.0L won't start

I have been experiencing this problem for several weeks now.

It will run fine for days and then all of a sudden NOTHING.

I have checked several things for the cause of the problem i.e.; Fuel Pump, Fuel Pump Relay, Fuel Filter, etc...

I was reading that it might be the Cranckshaft Position Sensor?? I was told that it was located on the driver's side of the bellhousing and it was a PITA to get off but for some reason I cannot locate this mystery part?? there is nothing on the drivers side of the bellhousing on my JEEP and now my JEEP is not starting at all. It usally starts after awhile but today it just cranks and cranks

anything anyone can suggest would be GREAT!!!

thjofe is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-27-2006, 06:09 AM
balloo93
Little Red Menace
 
balloo93's Avatar
1993 XJ Cherokee 
 
Join Date: Aug 2002
Location: Austin, TX
Posts: 20,820
Look into the engine compartment and floow the bell housing up and down till you find a wiring harness (couple of wires in a loom) coming out of it. The sensor is pretty well recessed into the housing.

Find it and find the connector for it. Disconnect it and reconnect it a couple of times to clear the contacts. The try it again.

93 Sport
Beer is proof that God loves us and wants us to be happy............Ben Franklin


Specs in Profile.

http://www.cardomain.com/ride/325707/1
http://www.cardomain.com/ride/2406854/1
balloo93 is offline  
post #3 of 5 Old 09-27-2006, 09:57 PM
severous01
Registered User
 
severous01's Avatar
 
Join Date: Jan 2006
Location: SETX, TX
Posts: 2,147
also look into a factory alarm. my chip fried and was making a semi-connection...sometimes. i had to remove the alarm and then i had no problems...and still dont over 5k miles later...happy as can be.

oh, an easy way to test this is to short the starter relay (with it in neutral or park) and see if it still starts...or beat the starter a few times with a deadblow or rubber mallet to see if it's the starter.
severous01 is offline  
post #4 of 5 Old 09-27-2006, 11:07 PM
xjawgi
Registered User
 
Join Date: Jan 2006
Posts: 9
that thing on the bellhousing is a crank position sensor, and yes it could be the cause of your no start problem.
xjawgi is offline  
post #5 of 5 Old 09-27-2006, 11:30 PM
Jeepin_XJ_101
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2005
Posts: 866
Quote:
Originally Posted by xjawgi
that thing on the bellhousing is a crank position sensor, and yes it could be the cause of your no start problem.


11 O'Clock position of the bellhousing if your looking from the tranny, 1 O'Clock if your looking from the engine bay. The connector is right behind the throttle body. It is held on the bellhousing by 2 bolts spaced like 2 inches apart with the sensor inbetween. Hope that was descriptive enough.

"When in doubt... Floor it"
1989 XJ 4.0L I6 - AX-15 Swap - NP231 - 4" RC - 33x13.50 MT Claws
*SOLD*

2005 WK 4.7L 3.5" RK, 255/75R17 on Rubi Wheels
1992 YJ 4.0L 5" ProComp on 35x12.50 Trxus MT
Jeepin_XJ_101 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
94 Grand Cherokee Laredo won't start. iguana5000 XJ Cherokee Technical Forum 2 12-18-2009 03:33 PM
1990 Jeep Cherokee will crank but not start ridebmxfbm XJ Cherokee Technical Forum 9 09-20-2009 10:31 AM
1990 cherokee hard start- need PN and ? vintage_car XJ Cherokee Technical Forum 0 11-19-2008 09:13 AM
92 Cherokee Laredo 4.0 won't start issue. pseverin XJ Cherokee Technical Forum 1 04-24-2007 06:50 PM
Would newer '00 flares fit my 1990 cherokee laredo twisted_ed XJ Cherokee Technical Forum 2 11-08-2004 04:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome