1987 Wagoneer 4.0 auto bad fuel pump? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 08-12-2010, 12:35 AM Thread Starter
JeepRyderz
Registered User
1987 XJ Cherokee 
 
Join Date: Jun 2010
Location: Peoria
Posts: 15
1987 Wagoneer 4.0 auto bad fuel pump?

So, I left for school got about a mile away and lost acceleration, push the gas pedel and absolutely nothing happens, still had power steering but only for a few seconds before the Jeep just died. When I tried to start it back up it was turning over and sounded like it was going to start up, then eventually it was just cranking. Checked if I had spark and I do. Checked the relay switch with my DMM and its fine. Is there anything else I'm overlooking before I try replacing the fuel pump?

JeepRyderz is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-12-2010, 05:47 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,109
Check for power to the fuel pump. Could be a bad fuel pump relay. On the driver side fender well there's a white ballast resistor with a wire at each end. 87s didn't all have them originally but there was a campaign to install the resistors to quiet down the fuel pumps. Make sure you've got power going into and out of the resistor with the fuel pump energized. If not, just eliminate the resistor temporarily to get it to start. You can always permanently eliminate the resistor if you don't find the fuel pump noise objectionalbe. When I worked at the dealership back then, it was only the fuddy-duddies that complained about the noise anyway.
cruiser54 is offline  
post #3 of 3 Old 08-12-2010, 05:55 AM Thread Starter
JeepRyderz
Registered User
1987 XJ Cherokee 
 
Join Date: Jun 2010
Location: Peoria
Posts: 15
Well the fuel pump turned out to be fine. I guess when I turned onto the main road the pump shifted weird and the strainer fell off and the hose between the sender unit and the pump disconnected. So happy, now I can get my money back for the pump. Had to drop the tank and stick my arm in to grab everything that fell out. Not to mention I had a completely full tank so I had to slowly drain it out. Just glad she's running again.
JeepRyderz is offline  
Reply

Tags
4.0 , fuel pump , i6 , jeep , wagoneer

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
fuel pump relay location on 1987 jeep cherokee 4.0 rgjeep XJ Cherokee Technical Forum 8 12-15-2010 12:49 PM
88 4.0 auto fuel pump always runs.. regulator or pump? robdoggydog1 XJ Cherokee Technical Forum 11 01-29-2010 06:33 PM
having fuel pump problems w/96 v6,auto 2wd grayskull XJ Cherokee Technical Forum 2 01-30-2009 06:01 PM
1987 XJ Wagoneer.. Ran out of fuel, refilled, now wont run? hp383 XJ Cherokee Technical Forum 19 06-17-2006 09:01 PM
1987 fuel pump in tank or not???? mightyone XJ Cherokee Technical Forum 5 08-12-2003 01:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome