1987 Wagoneer 4.0 auto bad fuel pump? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 1987 Wagoneer 4.0 auto bad fuel pump?

Smittybilt Products at Oconee Off-Road!Building a Bumper?Ruffstuff Axle Simple Swap Kit!

Reply
Unread 08-12-2010, 12:35 AM   #1
JeepRyderz
Registered User
1987 XJ Cherokee 
 
Join Date: Jun 2010
Location: Peoria
Posts: 15
1987 Wagoneer 4.0 auto bad fuel pump?

So, I left for school got about a mile away and lost acceleration, push the gas pedel and absolutely nothing happens, still had power steering but only for a few seconds before the Jeep just died. When I tried to start it back up it was turning over and sounded like it was going to start up, then eventually it was just cranking. Checked if I had spark and I do. Checked the relay switch with my DMM and its fine. Is there anything else I'm overlooking before I try replacing the fuel pump?

JeepRyderz is offline   Reply With Quote
Unread 08-12-2010, 05:47 AM   #2
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,791
Check for power to the fuel pump. Could be a bad fuel pump relay. On the driver side fender well there's a white ballast resistor with a wire at each end. 87s didn't all have them originally but there was a campaign to install the resistors to quiet down the fuel pumps. Make sure you've got power going into and out of the resistor with the fuel pump energized. If not, just eliminate the resistor temporarily to get it to start. You can always permanently eliminate the resistor if you don't find the fuel pump noise objectionalbe. When I worked at the dealership back then, it was only the fuddy-duddies that complained about the noise anyway.
cruiser54 is offline   Reply With Quote
Unread 08-12-2010, 05:55 AM   #3
JeepRyderz
Registered User
1987 XJ Cherokee 
 
Join Date: Jun 2010
Location: Peoria
Posts: 15
Well the fuel pump turned out to be fine. I guess when I turned onto the main road the pump shifted weird and the strainer fell off and the hose between the sender unit and the pump disconnected. So happy, now I can get my money back for the pump. Had to drop the tank and stick my arm in to grab everything that fell out. Not to mention I had a completely full tank so I had to slowly drain it out. Just glad she's running again.
JeepRyderz is offline   Reply With Quote
Reply

Tags
4.0 , fuel pump , i6 , jeep , wagoneer
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.