1987 jeep wagoneer problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > XJ Cherokee Technical Forum > 1987 jeep wagoneer problems

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueXHD Heavy-Duty Hood Latches for JK and TJ available at OcoStainless Steel Door Hinge Pins

Reply
Unread 01-04-2010, 09:36 PM   #1
xj1987Wagon
Registered User
1987 FSJ Wagoneer 
 
Join Date: Jan 2010
Location: Maryland
Posts: 2
1987 jeep wagoneer problems

Ok i have a 1987 Amc Jeep Wagoneer and its story is..(its kinda long).. but any way i bought this jeep a few days ago and all seemed well when i picked it up well.. on the way home on the highway rolling at around 55 60 it just died rpms dropped to 0 and then a few seconds later it came back like nothing happend it did it a few more times down the road and it died when the fuel light came on which is around a quarter of a tank and that was around 60 miles so i figured it had water in the tank so i got it towed by my friend who was with me who was in a 92 jeep cherokee looks just like my wagoneer.. he towed me to the gas station and we filled the gas tank back up and started her back up ran fine no problems we got back on the road home and around 5miles into the trip it died again at a red light and i couldnt get it started for around 5 - 10 min got it started and kept the RPMs up and it ran fine it only dies when your at crusing rpms around 2k 2.5k rpms. well we got it home finally and parked it for the night woke up and drove it back to my friends house (he has alot of jeeps) he looked over it and everything seemed ok (it drove fine to his house which is about 25 30 miles from mine) now we left his house and it maybe of died once on the way home (this whole time im basicaly thinking ok theres more water in the tank) so i get it home let it sit over night again go out and i mess with a few things just goin over it (not really messing with anything all i really did was fix the map sensor hose cuz it was leaking) started it up and it was runnin just fine so i figured maybe all is well now. ( ive worked on alot of cars and vacume leaks will cause all kinds of problems) so i just left it alone driving it about 5 -10 miles a day back and forth from work for a few days with no problems... we took it out today and had been driving most of the day (i changed the fuel filter today as well in about the middle of all our driving) and it died again prob around 30 miles of driving so i then changed the fuel filter at walmart parking lot then we got in the jeep and was driving home and after about 12miles into the trip it died and wouldnt start i finally got it started and had to keep the RPMS up to keep it running so i put my foot to the floor and tried to get it home about 5miles away it made it about a quarter mile before dieing by now im frustrater so im giving it gas tryin to get it started it starts so i gun it hoping to get it home it makes it about a mile then nothing cant get it to start nothing it turns over and fires once and kinda seems like its running but its making a weird noise that i cant even exsplain and then dies then a few times it starts revs up let it fall to idle and it dies so im lookin under the hood trying to figure out whats going on nothings unhooked nothing looks messed up so i just let it sit for a lil bit then start it and after a few trys it starts and i finally make it home.... does anyone here have any idea at all..( its not the fuel pump cuz i hear it kick on and it had pressure cuz when i loosened the clamp on the fuel filter i just barley got it loose and gas came blasting out!).. any help would be great.. now i know i just wrote a book and theres prob alot of useless crap in there but i just wanted to make sure i gave as much detail as possible.. ive worked on cars and in know more then anyone the more details the better... thanks everyone!

xj1987Wagon is offline   Reply With Quote
Unread 01-06-2010, 08:04 AM   #2
xj1987Wagon
Registered User
1987 FSJ Wagoneer 
 
Join Date: Jan 2010
Location: Maryland
Posts: 2
ok well i think we figured it out.. i can start it go under the hood and push on the plugs to the coil and it will die.. so we used some elctric grease and pushed them back in after cleaning the connectors.. and now it doesnt do it as much but its still doin it so im gonna have to replace the coil.. 51$ at my local autozone :-( but hey its gotta get done.. hopefully this will fix it....
xj1987Wagon is offline   Reply With Quote
Unread 01-06-2010, 08:29 AM   #3
mickc9129
Registered User
 
Join Date: Apr 2008
Location: whittier
Posts: 312
With what you mention above, I'd check out the wire to the coil first.
mickc9129 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.