Winter Rims -

LinkBack Thread Tools
post #1 of 1 Old 10-20-2010, 07:59 PM Thread Starter
Registered User
2005 KJ Liberty 
Join Date: Jan 2010
Location: Ontario, Canada
Posts: 35
Winter Rims

I need steel rims for my new winter tires. I went to Canadian Tire and they said they only have multi-fit rims which will fit but the center hole in the rim where the hub is might be larger as it is designer for many vehicle types. So my question is does the hole need to be tight around the hub of my Liberty?

Also if it does where is a place to buy the proper winter rims?

JeepPower is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Winter storms kshanayda Great Lakes USA 16 01-18-2009 07:30 PM
Winter Trip tlgraham North Dakota Jeep Forum 0 01-09-2009 08:16 PM
Has Anyone Hit Fordyce During The Winter? jclark50 California Jeep Forum 11 11-19-2008 03:06 PM
Winter tires cwevenson Canada 2 11-06-2007 07:52 PM
Wheeling Before the winter. Allenwr California Jeep Forum 3 10-13-2007 07:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome